Blogengine 2.5 Login Failed with Correct Credentials

Feb 19, 2013 at 12:27 PM
A few weeks ago blogengine no longer let me log in. I keep reaceiving an error box at the top of the page that says, "Login Failed." This is not a dotnet error page or a database error. The database works, because the posts appear. However, login no longer works and neither does email. I checked the database and I am typing in the correct user name and password. If it helps, the blog is hosted on godaddy. It is running on dotnet 4.0 and the pipeline is integrated not classic. I would really appreciate the help in resolving this matter. Thanks.
Feb 19, 2013 at 8:08 PM
You can try to reset password. If you are using DB, you need only update user record setting password to empty string, then BE will generate and encrypt default "admin" password:

How do I reset lost admin password?
If you are using default XML provider:
  1. Get to your website (usually by FTP to your web server).
  2. Open /app_data/users.xml in the text editor, for example notepad.
  3. Remove password from your admin account, meaning:
change from:


If you are using SQL then instead of XML file update DB table:
UPDATE be_Users SET Password = '' WHERE UserName = 'admin'
  1. Restart web site, easiest way is to open web.config and add a space to the comment and save it. Comments are:
<!-- anywhere between tags like these --> Now you should be able to log in as admin/admin.

If you don't have Admin account in the users.xml file, add new user tag like so:

<Email></Email> <LastLoginTime>2007-12-05 20:46:40</LastLoginTime>

Once logged in as admin, you can delete and create again any user account from admin panel.
Feb 28, 2013 at 4:33 PM
Thanks Rtur,

I read your replies from other issues and happy to see your response on my issue.
I apprecitate your tips.

Now, my problem changes.
I got the Admin and password from my manager, then, it passed me in.
But, the functions of "Add Entry", "Profiles" and "Users" are not working, and "Add entry","Controls" and "Categories" are working.
The articles are displaying, and I can delete them, but I cannot add or edit them.

Our blog is customized and using DB.

When, I run the project in Visual Studio 2010, the blog.cor.provider is looking for a file named DbMembershipProvider.cs, but, that file is no longer exist because we moved to a new server.

I got an error on Line 349 foreach statement, and actual message is copied here:

Any idear about this?

Line 347: private void BindUsers()
Line 348: {
Line 349: foreach (MembershipUser user in Membership.GetAllUsers())
Line 350: {
Line 351: ddlAuthor.Items.Add(user.UserName);

Source File: c:\inetpub\wwwroot\\blog\admin\Pages\Add_entry.aspx.cs Line: 349

Stack Trace:

[SqlNullValueException: Data is Null. This method or property cannot be called on Null values.]
System.Data.SqlClient.SqlBuffer.get_DateTime() +5270860
System.Data.SqlClient.SqlDataReader.GetDateTime(Int32 i) +80
BlogEngine.Core.Providers.DbMembershipProvider.GetAllUsers(Int32 pageIndex, Int32 pageSize, Int32& totalRecords) in C:\Users\usuglatwala\Documents\Visual Studio 2008\WebSites\SDTimes3.0\BlogEngine.Core\Providers\DbMembershipProvider.cs:591
System.Web.Security.Membership.GetAllUsers(Int32 pageIndex, Int32 pageSize, Int32& totalRecords) +45
System.Web.Security.Membership.GetAllUsers() +26
admin_entry.BindUsers() in c:\inetpub\wwwroot\\blog\admin\Pages\Add_entry.aspx.cs:349
admin_entry.Page_Load(Object sender, EventArgs e) in c:\inetpub\wwwroot\\blog\admin\Pages\Add_entry.aspx.cs:35
System.Web.Util.CalliEventHandlerDelegateProxy.Callback(Object sender, EventArgs e) +51
System.Web.UI.Control.OnLoad(EventArgs e) +92
System.Web.UI.Control.LoadRecursive() +54
System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +772
Feb 28, 2013 at 5:53 PM
I doubted that file is missing, all classes in BlogEngine.Core compiled into DLL and should not be on the server. You probably running older version, and I remember we had issue with international date conversion for languages that us "dd/mm/yyyy" format instead of "mm/dd/yyyy" - this could cause an issue. But if code was modified, there is no way for me to tell what is going on. If you running it in VS, you should be able to step through debugger and see exactly what is happening.
Feb 28, 2013 at 8:52 PM
Thanks rtur,

When I run it through Visual Studio. I got the errors of missing controls ids, but that controls are there with the correct name.
I tried replace them but no changes.

eg) The name "divLable" does not exist in the current context......