This project is read-only.

Unable to send emails

Topics: Controls
May 12, 2013 at 9:55 AM
I can't seem to get the email contact settings correct.

I want to send via

I've set the SMTP server as For the port number I've tried both 25 and 587, and I've also tried both with and without SSL enabled.

The response message is "the user was not authenticated".

Am I missing something?
May 12, 2013 at 1:40 PM
Did you specify valid user name and passwords for the SMTP account?

Which destination e-mail address did you use? When I setup the e-mail I had to use a destination address in the same domain of the SMTP server - i.e. you should use '' as the destination address. (This seems a bug to me, but I did not investigate further)
May 12, 2013 at 3:36 PM
I'm specifying my own personal email address as both the email address to send via, and the username. The password is the same password I log in to with.

I don't have a address, and I'm not sure they're still available.

I've just tried changing the SMTP address to (the email address is my name, and the error message is "The SMTP server requires a secure connection or the client was not authenticated. The server response was: 5.7.1 Client was not authenticated". - And this despite the SSL box being checked.
May 13, 2013 at 8:47 AM
Edited May 13, 2013 at 8:47 AM
Possibly your hosting provider is blocking outbound SMTP? Or is not accepting inbound connections from your hosting provider?

(I had similar problems trying to use GMail, in the end I had to use my provider's SMTP)
May 14, 2013 at 9:05 AM
I suspect is looking for something different to what BE.NET sends, which seems just a little strange. I know BE.NET is not developed by Microsoft, but it is written on their framework, and when you consider how integrated Microsoft's services are becoming, sending via is kind of expected.

I've also used other third party apps - both Thunderbird and GMail can connect to - so what is BE.NET not doing?

Looks like I'll have to set up an email account on my hosting server and try that instead.
May 14, 2013 at 3:15 PM
That would be stranger if SMTP had some special outlook powers, considering it was written way before outlook showed up :)
I have "msn" account which became "live" and then "outlook", so I log into outlook using "" email address.
I can connect to on port 587 from BE running on Azure, with SSL on, and it sends email to my outlook inbox.
Nov 27, 2013 at 12:51 AM
Edited Nov 27, 2013 at 12:52 AM

I would be interested to know how you got email to work in Azure without SendGrid or something like it? :-)
Nov 27, 2013 at 5:53 AM
Edited Nov 27, 2013 at 5:55 AM
I'm using these settings, just clicked "test" button again to be sure and it is sent me a message, no 3rd party required. Maybe, depends on account? As I said, mine is not "outlook" but older "msn" and it might get routed differently, but it sure works fine.