Theme Help!!!

Topics: ASP.NET 2.0, Themes
Jan 17, 2009 at 10:27 PM
I would like to know how i can change my theme manually from my Host-server folder
because my blog is not show on the browser and i got the this error..

[HttpException (0x80004005): The file '/blogEngine/themes/Mobile/site.master' does not exist.]
Coordinator
Jan 17, 2009 at 11:46 PM
The preferred way to change your theme would be on the Settings tab in the Control Panel.  You can also change your theme directly in the settings.xml file in your App_Data folder.  If you do this, your blog may not detect the change right away.  Re-uploading your web.config file should cause this manual change to be detected.
Jan 18, 2009 at 1:26 AM
how can i make the changes on the setting.xml file and what i have change to use the theme that i want to use?
Coordinator
Jan 18, 2009 at 4:04 AM
If you're not familar with the settings.xml file, I'd recommend you change you theme on the Settings tab in the control panel.  On that tab, there will be a dropdown list of themes you can choose from.
Jan 18, 2009 at 9:09 PM
Ben thank you for responding to my post, but my problem is that my blog is not display on any browser, that is why i have to it manually on my host server. can u tell how do it?
Coordinator
Jan 18, 2009 at 10:11 PM
You can always change theme by going to http://yoursite.com/admin/Pages/Settings.aspx
Jan 18, 2009 at 10:23 PM
Appears you didn't upload the mobile theme.  Upload it and then you can switch themes.  Remove if necessary.  I run into this when I'm using a SQL Server provider and forgot to script out the updates.  Hope this helps.
Coordinator
Jan 18, 2009 at 11:57 PM
You can try going directly to the Settings page as rtur suggested, but you might end up getting kicked out to the login page which also uses the non-existant master page.

If you don't have a "mobile" folder in your themes folder, then you will want to upload the "mobile" folder into your themes folder as Brian suggests.

You can manually change the theme in your settings.xml file.  In that file, the theme setting will look like:

<theme>Mobile</theme>

You can change that to a theme you have in your themes folder.  For instance, to change it to the Standard theme, you should change that line above to:

<theme>Standard</theme>

Whatever theme you choose, there should be a folder under the themes folder with the same name as the theme you put into the settings.xml file.
Jan 19, 2009 at 2:14 AM
On the setting.xml  file there are to line of code like this:
<theme>Standard</theme> and another like this: <mobiletheme>Mobile</mobiletheme>
Do i have to change both line of code or only the one with the mobile theme?
and when i make the changes should look like this:  <dirtylicioustheme>Dirtylicious</dirtylicioustheme>


Coordinator
Jan 19, 2009 at 3:32 AM
Are you using a mobile device to view your blog?  You can try changing

<mobiletheme>Mobile</mobiletheme>
-- change to --
<mobiletheme>Standard</mobiletheme>

But also make sure the Standard theme folder is in your "themes" folder.  Your themes folder should have one or more sub-folders underneath it.  Each subfolder is a theme.  If you were to download BlogEngine 1.4.5, there are 3 folders in the themes folder -- Indigo, Mobile and Standard.  These are themes ... Indigo theme, Mobile theme and Standard theme.
Jan 19, 2009 at 6:15 AM

Thank you Ben! It helped a lot.

On Jan 18, 2009 10:32 PM, "BenAmada" <notifications@codeplex.com> wrote:

From: BenAmada

Are you using a mobile device to view your blog? You can try changing

<mobiletheme>Mobile</mobiletheme>
-- change to --
<mobiletheme>Standard</mobiletheme>

But also make sure the Standard theme folder is in your "themes" folder. Your themes folder should have one or more sub-folders underneath it. Each subfolder is a theme. If you were to download BlogEngine 1.4.5, there are 3 folders in the themes folder -- Indigo, Mobile and Standard. These are themes ... Indigo theme, Mobile theme and Standard theme.

Read the full discussion online. To add a post to this discussion, reply to this email (blogengin...