Email settings with godaddy.

Topics: ASP.NET 2.0
Jan 26, 2009 at 3:34 AM
I tried following settings with Godaddy, but Email feature is not working. 

server name : relay-hosting.secureserver.net  

port: 25 default

usename is left blank

password left blank

and unchecked enable SSL


Am i missing anything here?
Coordinator
Jan 26, 2009 at 4:54 AM
Does email work in any part of BE?  For instance, can you send a test email on the Settings tab in the Control Panel.  If that works, but email isn't working on the Contact page or comment notifications, there was this recent discussion (see the last few posts in particular).
Jan 26, 2009 at 12:52 PM
Are you using dedicated server with GoDaddy or is it sharing hosting? I have dedicated server where I have hosted BlogEngine and I don't seem to be having any issues with email send. Thing you may want to check is "server name" setting. I know for dedicated servers, there is a specific relay server that gets used. If you need any help with setting up email settings for goddady feel free to ping me.
Jan 26, 2009 at 3:25 PM
Edited Jan 26, 2009 at 3:28 PM
Thanks to both for your quick reply!!

It's Deluxe Hosting - Windows . I think it is shared hosting. I tried following settings

E-mail address: XXXx@gmail.com
SMTP server:  relay-hosting.secureserver.net
Port number:25
Username: blank
Password: blank
Both chcekboxes unchecked
Subject prefix: Weblog

I also tried by entering both username & password, but no luck.
Coordinator
Jan 26, 2009 at 10:17 PM
I could be wrong, but I think the email address has to be an email address you have setup at GoDaddy.  So, it would be UserName@YourDomain.com, and can't be a Gmail address or any other offsite address.
Coordinator
Jan 26, 2009 at 11:33 PM
Also, if you want to use your gmail account as the "From" address, you should be able to do that.  Scott was just asking about this over in this thread.  Google says what your settings should be here.

I'd try using port 25 instead of 465 or 587.  You do need to use a username/password when sending through smtp.gmail.com.  Username is your email address and password is your email password.
Jan 27, 2009 at 2:39 AM
I tried smtp.gmail.com with different port numbers. But test mail is not working.

I am not sure, why these settings are not working.

http://www.codeplex.com/blogengine/Thread/View.aspx?ThreadId=38192
Coordinator
Jan 27, 2009 at 3:17 AM
The settings in that thread are for sending email through GoDaddy's mail server (relay-hosting.secureserver.net).  They're not going to let you send email through their server if the "From" address is a gmail.com account.

The settings in your original post look like they would work as long as the Email Address you specify on the Settings tab in the control panel is an email account you have setup on your mail server at GoDaddy.  In that other thread you referenced, LifterCatcher got it to work with a blank username/password.  saratogacoach needed to specify a username/password.  You could try both ways.  The username/password would probably be your email account at GoDaddy for the username and your email account's password.
Jan 27, 2009 at 4:13 PM
Edited Jan 27, 2009 at 4:17 PM

Hi BenAmada,

Thanks for your help. I got message saying "Test successfull " . But i didn't recieve any email. I also tried using contact page. Here are my settings.

E-mail address: username@myDomainName
SMTP server:  relay-hosting.secureserver.net
Port number:25
Username: blank
Password: blank
Both chcekboxes unchecked
Subject prefix: Weblog

I also tried by entering both username & password, but no luck.

Ps: i am using blogengine 1.3xx

Coordinator
Jan 27, 2009 at 8:50 PM
I just took a quick look at BE 1.3's code since I hadn't seen it before.  The code to send a test email on the Settings tab in the control panel looks the same in 1.4.5 as it does in 1.3.  Your settings seem right, and offhand, I'm not sure why you wouldn't be getting the mail.  You could try running it by GoDaddy support to see if they can help.  Have you ever sent email through that "username@myDomainName" account before?

I had a GoDaddy account way back when, and I seem to recall there being some type of "Allow SMTP Relay" setting within GoDaddy's email setup.  If this option is there, you may need to turn it on so GoDaddy's mail server will allow email to be relayed through its server.

For your contact page, in contact.aspx.cs, in the SendEmail routine, there's this line:

mail.From = new MailAddress(txtEmail.Text, txtName.Text);

That's trying to set the "From" address to the email address of the person leaving the message.  This basically causes the same problem you had before by trying to set the "From" address to your gmail account.  What that line above should be (and is in BE 1.4.5) is:

mail.From = new MailAddress(BlogSettings.Instance.Email);

This will set the "From" address to your "username@myDomainName.com" address.  If the contact page works at that point, you could try adding a ReplyTo header set to the person who left the contact message.  The advantage of this is if you Reply to the email, your email program will put the other person's email address in the To field instead of your own email address.  The ReplyTo line you could optionally add after the mail.From line would be:

mail.ReplyTo = new MailAddress(txtEmail.Text, txtName.Text);
Jan 28, 2009 at 6:07 PM
Thanks BenAmada!! finally i got it working. Here are my settings ..

E-mail address: username@myDomainName
SMTP server:  relay-hosting.secureserver.net
Port number:25
Username: 
username@myDomainName
Password: xxxxx
Both chcekboxes unchecked
Subject prefix: Weblog

Thanks again, i really appreciate your help.