I am trying to convert to using mySQL Server. The script ran fine and created the tables. I get the following error when connecting after making the changes to my web.config.

Topics: ASP.NET 2.0, Business Logic Layer, Controls
Jan 29, 2009 at 9:50 PM
Edited Jan 29, 2009 at 9:51 PM
i have had it working NOT ON a SQL server using xml, but this site will have high demand so i would like some help PLEASE!!! i have been up now for over 38 hours trying to get this to work.
thesite is http://blog.virtus.org.au/blog/
the message is 


Server Error in '/blog' Application.

Configuration Error

Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

Parser Error Message: Could not load file or assembly 'MySql.Data, Version=, Culture=neutral, PublicKeyToken=c5687fc88969c44d' or one of its dependencies. The located assembly's manifest definition does not match the assembly reference. (Exception from HRESULT: 0x80131040)

Source Error:

Line 49: 		<compilation debug="true">
Line 50: 			<assemblies>
Line 51: <add assembly="MySql.Data, Version=, Culture=neutral, PublicKeyToken=C5687FC88969C44D"/>Line 52: 				<add assembly="System.Management, Version=, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A"/>
Line 53: 				<add assembly="System.Configuration, Version=, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A"/>

Source File: C:\Inetpub\vhosts\virtus.org.au\httpdocs\blog\blog\web.config    Line: 51

Assembly Load Trace: The following information can be helpful to determine why the assembly 'MySql.Data, Version=, Culture=neutral, PublicKeyToken=c5687fc88969c44d' could not be loaded.

WRN: Assembly binding logging is turned OFF.
To enable assembly bind failure logging, set the registry value [HKLM\Software\Microsoft\Fusion!EnableLog] (DWORD) to 1.
Note: There is some performance penalty associated with assembly bind failure logging.
To turn this feature off, remove the registry value [HKLM\Software\Microsoft\Fusion!EnableLog].

Version Information: Microsoft .NET Framework Version:2.0.50727.1433; ASP.NET Version:2.0.50727.1433

i have followed all the video prompts and the faq, but it still does not work.
can some one please help, and tell me how to fix this issue.

thanking you in advance  regards  adrian.
Jan 30, 2009 at 7:34 PM
Hi Adrian,

The error has to do with the MySQL.Data assembly.  What version have you loaded into your bin directory?  The sample web.config was written using 5.1.6 (which I believe was current at the time.)

Anyway, I'd update the assembly data to match the version you have and have loaded you your web host.

Good luck.

Feb 5, 2009 at 2:54 PM
Take a look at my post.  I address this very issue.