HEEEELLLLPPPPPPPP with loading blogEngine using Godaddy Hosting

Jan 30, 2009 at 4:07 PM
Hi, I am a frustrated newbie trying to load blogEngine.Net on onto my website hosted by GODADDY  but keep getting a 500 internal error! I have activated the write permissions for the app_data folder
to no avail.

Is there anything specific that I need to look out for? Do I have change anything in the config file? I am using windows.

Any advice will be much appreciated.
Coordinator
Jan 30, 2009 at 5:24 PM
Did you install BE yourself, or did you use the BE "automated" setup tool that GoDaddy provides?  Also, did you install BE into a subfolder, or the root of your site?
Jan 30, 2009 at 5:48 PM
I installed BE myself, and ftp'd to the root directory on the server using Filezilla ftp client. I also contacted godaddy help desk but they cant figure out what the problem is.

They emailed back saying it could be the webconfig file. So I am stranded now. Is using their BE an option? or will I end up in the same dead end?
Coordinator
Jan 30, 2009 at 7:07 PM
You could try using their BE option.  And yes, it could be a problem with your web.config file.

I'm guessing you're using BE 1.4.5?  What version of IIS is your site on, IIS6 or IIS7?  If you're on IIS7 and you're using the web.config file that came with BE 1.4.5, then that could be the problem (not positive though).  If you're on IIS7, you can try using the latest web.config file available on the Source Code tab above (changeset 24719) since it includes IIS7 support.  If that web.config file doesn't work and you're on IIS7, I would try removing the entire <httpHandlers> and <httpModules> sections out of that web.config file since all the handlers and modules are already defined in the <system.webServer> section.
Jan 30, 2009 at 7:36 PM
Hi BenAmada,

You are a STAR, it was the webconfig file. just replaced the old with latest and walla, it works! I am really really happy now.

Thanks a bundle.

Best Regards