ReferenceError: BlogEngine is not defined

Topics: Controls
Oct 1, 2013 at 6:50 PM
I just upgraded to web 2.8 from 1.6. When I go to a post, I get a js error:

ReferenceError: BlogEngine is not defined
BlogEngine.comments.flagImage = BlogEngine.$("imgFlag");

Try to click submit on comment and get
return BlogEngine.validateAndSubmitCommentForm()

I followed all the steps using a fresh install and moving my theme over, updating db, etc.

Any ideas?
Oct 1, 2013 at 7:16 PM
This appears to be something in my site.master. I tried moving some script links in but site won't load. Is there a theme I should start with and add in my styles? Main page works fine but it doesn't like something to do with the comments on a post. Thanks.
Oct 1, 2013 at 9:08 PM
I had an i6 css tag that the js links were attracted to :)
<!--[if IE 6]><link rel="stylesheet" href="/themes/blah/ie6.css" type="text/css" media="screen" /><![endif]-->
They would add themselves to the end and thus comment themselves out:
<!--[if IE 6]><link rel="stylesheet" href="/themes/blah/ie6.css" type="text/css" media="screen" />
        <script type="text/javascript" src="/en-gb.res.axd"></script>
    <script type="text/javascript" src="/Scripts/Auto/01-jquery-1.9.1.min.js"></script>
    <script type="text/javascript" src="/Scripts/Auto/02-jquery.cookie.js"></script>
    <script type="text/javascript" src="/Scripts/Auto/04-jquery-jtemplates.js"></script>
    <script type="text/javascript" src="/Scripts/Auto/05-json2.min.js"></script>
    <script type="text/javascript" src="/Scripts/Auto/blog.js"></script>
    <script type="text/javascript" src="/Scripts/App/widget.js"></script>
    <script type="text/javascript" src="/Scripts/App/qnotes.js"></script><![endif]-->