MySql 5 Install Issue

Feb 3, 2009 at 2:06 AM
Edited Feb 3, 2009 at 2:10 AM
Hi, I am running a completely new version of BE.NET 1.4.5 - If configure the application for an XML provider, everything works out ok and loads.  But, once I switch the providers via the web.config to be DbBlogProvider, DbRoleProvider and DbMembershipProvider, I start getting an error...  I copied the error to the bottom of this post.  I have also run the setup/instal sql script for the MySQL server and corrected all table name Cap settings...  any info would be greate here!!   Thanks

Column 'ExtensionType'cannot be null <o:p></o:p>

Description: An unhandled exception occurred during theexecution of the current web request. Please review the stack trace for moreinformation about the error and where it originated in the code.

Exception Details: MySql.Data.MySqlClient.MySqlException: Column 'ExtensionType'cannot be null

Source Error: <o:p></o:p>

<o:p> </o:p>

Line 1371:                    cmd.Parameters.Add(dpFile);<o:p></o:p>

Line 1372:<o:p></o:p>

Line 1373:                    cmd.ExecuteNonQuery();<o:p></o:p>

Line 1374:                }<o:p></o:p>

Line 1375:            }<o:p></o:p>


Source File: D:\Work\upfromthesky\BlogEngine.Core\Providers\DbBlogProvider.cs    Line: 1373

Stack Trace: <o:p></o:p>

<o:p> </o:p>

[MySqlException (0x80004005): Column 'ExtensionType' cannot be null]<o:p></o:p>

   MySql.Data.MySqlClient.MySqlStream.OpenPacket() +278<o:p></o:p>

   MySql.Data.MySqlClient.NativeDriver.ReadResult(UInt64& affectedRows, Int64& lastInsertId) +97<o:p></o:p>

   MySql.Data.MySqlClient.MySqlDataReader.GetResultSet() +87<o:p></o:p>

   MySql.Data.MySqlClient.MySqlDataReader.NextResult() +1092<o:p></o:p>

   MySql.Data.MySqlClient.MySqlCommand.ExecuteReader(CommandBehavior behavior) +1579<o:p></o:p>

   MySql.Data.MySqlClient.MySqlCommand.ExecuteReader() +32<o:p></o:p>

   MySql.Data.MySqlClient.MySqlCommand.ExecuteNonQuery() +69<o:p></o:p>

   BlogEngine.Core.Providers.DbBlogProvider.SaveToDataStore(ExtensionType exType, String exId, Object settings) in D:\Work\upfromthesky\BlogEngine.Core\Providers\DbBlogProvider.cs:1373<o:p></o:p>

   BlogEngine.Core.Providers.BlogService.SaveToDataStore(ExtensionType exType, String exId, Object settings) in D:\Work\upfromthesky\BlogEngine.Core\Providers\BlogService.cs:368<o:p></o:p>

   BlogEngine.Core.DataStore.ExtensionSettingsBehavior.SaveSettings(ExtensionType exType, String exId, Object settings) in D:\Work\upfromthesky\BlogEngine.Core\DataStore\ExtensionSettingsBehavior.cs:39<o:p></o:p>

   BlogEngine.Core.DataStore.SettingsBase.SaveSettings(Object settings) in D:\Work\upfromthesky\BlogEngine.Core\DataStore\SettingsBase.cs:55<o:p></o:p>

   ExtensionManager.SaveToStorage(ManagedExtension ext) in d:\Work\upfromthesky\wwwroot\App_Code\CSCode\BlogEngine\ExtensionManager\Manager.cs:395<o:p></o:p>

   ExtensionManager.LoadExtensions() in d:\Work\upfromthesky\wwwroot\App_Code\CSCode\BlogEngine\ExtensionManager\Manager.cs:192<o:p></o:p>

   ExtensionManager.ExtensionEnabled(String extensionName) in d:\Work\upfromthesky\wwwroot\App_Code\CSCode\BlogEngine\ExtensionManager\Manager.cs:59<o:p></o:p>

   ASP.global_asax.Application_Start(Object sender, EventArgs e) in d:\Work\upfromthesky\wwwroot\Global.asax:44<o:p></o:p>

<o:p> </o:p>


Version Information: Microsoft .NET Framework Version:2.0.50727.3053; ASP.NETVersion:2.0.50727.3053



Feb 3, 2009 at 9:12 PM
I can't believe there is no response to this...  mysql is a feature and it's not working.. so....  someone out there has to have experienced this!?  Any help would be appriciated.  Maybe some of the people who test or work on the code base!?  

Feb 4, 2009 at 7:27 PM
Figured it out.  I will avoid the verbose method and just drop the easy way.  If you are planning on using the MySQL database, then use the MySQL web.config in the setup directory. Then, customize it to what you need.  What I did wrong was use the regular blogengine.net web.config and then add the MySQL parts to it.  Didn't work out to well.  Thanks for all the help guys!  oh wait...  thanks to me ;)