SQL (MSSQL2005) server config questions

Feb 4, 2009 at 1:48 AM
Just started trying the software (v1.4.5)

got default install working using XML
setup BE database, ran scripts, changed webconfig.xml and went back to blogEngine site:

Blog Entry now read "If you see this post it means that BlogEngine.NET 1.4.5 is running with SQL Server and the DbBlogProvider is configured correctly." 

However:

  • Users still seem to be created in users.XML file and not in be_Users table on SQL - is this correct behavior? 
  • I am not able to manage anything (settings/users/etc) without write permissions to app_data directory with SQL settings.  I understand that attachments etc would need write access there - but if it is just users & posts, is all the data stored on the SQL server?
  • Managing User Profiles - selecting a name from the drop down and choosing "swith to user profile" (yes swith is missing the 'c' in the application), it does NOT switch to the selected users profile.  I'm not sure if this is DB related or not as I didn't try this under the XML config.

Thanks.

Feb 4, 2009 at 4:53 AM
Edited Feb 4, 2009 at 4:55 AM
Nevermind on bullets 1 and 2 - i'm just slow.


on point three: i found if the newly selected user does not have a profile, it keeps the textboxes populated with the data from the previously selected user.  Worse than that, it seems it then saves the data to both the previously selected user and the newly selected user.
Coordinator
Feb 4, 2009 at 5:06 AM
Yeah, the profiles page in 1.4.5 has problems, like you've noticed.  These problems are fixed in the latest build of BlogEngine available on the Source Code tab above.  I'm pretty sure you can safely overwrite your Profiles.aspx and Profiles.aspx.cs files in the admin\Pages directory with the latest versions of these files if you download the latest changeset (Source Code tab).