Live Writer connection Error?

Feb 19, 2009 at 1:07 AM
Edited Feb 19, 2009 at 1:09 AM
When trying to connect and write with Windows Live Writer I receive a connection error:
BE 1.4.5.13
Unhandling Exception in Live Writer connecting to http://fitness1st.net/blog/metaweblog.axd
Founds Found

Used to work fine until I upgraded to the newer version to correct the sqlconnection errors
Any help would be great!
Coordinator
Feb 21, 2009 at 5:15 AM
Edited Feb 21, 2009 at 5:17 AM
BE 1.4.5.13 actually covered a pretty wide span of releases.  Changeset 22964 released on Dec 12, 2008 was BE 1.4.5.13.  And 16 more releases after changeset 22964 all had the version number 1.4.5.13 ... all the way until Jan 31, 2009 when changeset 24796 was released.  During all these releases, the version number wasn't incremented.

You don't happen to remember which changeset you are using?  Although looking through the comments for all these releases, there doesn't appear to really have been any WLW changes.  Changeset 24796 had a WLW2009 Date fix.

Are you using the old WLW 2008 version?  WLW version 2009 appears to be officially released now.  If you're still on 2008, you could try 2009 to see if it makes a difference.
Coordinator
Feb 21, 2009 at 5:24 AM
Also, if you haven't tried this, you could try deleting your blog account in WLW and add it again.  I have no idea if this would help, but is just a general troubleshooting tactic ...
Feb 23, 2009 at 2:05 AM
Tried to delete the account and add it again.  No LUCK but thanks for the idea.
Coordinator
Feb 23, 2009 at 4:22 AM
Just for fun, in both WLW 2008 and WLW2009, I tried adding an account for your blog (using the URL you provided).  I also get an error.  The WLW 2008 error is ...

Blog Server Error - Server Error 01 Occurred
Invalid XMLRPC Request. (StartIndex cannot be less than zero. Parameter name: startIndex)
You must correct this error before proceeding.


The WLW 2009 error is similar.

I don't get this error when connecting to my 1.4.5 blog or a test BE setup using the latest changeset 25288.

I'm guessing when you upgraded, you compiled the BE core project in the changeset you downloaded and put the compiled BlogEngine.Core.dll file in your BIN folder?  Is everything else in your blog working correct since the upgrade?

Sorry, I don't have any solutions to provide.  Just wanted to confirm that I get this error too ... so it's not a problem with your WLW installation.  I'm guessing something didn't get upgraded correctly.