This project is read-only.

Saving the Comment = hung page, comment doesn't save

Topics: ASP.NET 2.0, Controls
Feb 21, 2009 at 5:49 AM
Problem: Add comment appears to work, including pulling Gravitar and Preview showing w/ date-stamp, email, source IP info, etc., but after clicking Save Comment button, the progress indicator spins indefinitely with "Saving the comment..." visible.  Will not go away until navigating away from the page.  Have tried with custom theme and standard, same results.  No errors are generated, just a hung page and comment doesn't save when coming back to the page.

Running Server 2008 Std 32-bit
Running SQL 2005 SP3 -- BE configured for Membership Provider / Role Provider
Running IIS7 in Medium Trust with successful modifications in Issue 6622 for the <trust level="Medium" originUrl=".*"/>
Verified Network Service has permission to BE.NET folder.
Comment settings are as follows:
Enable Comments: yes
Show Country: yes
Enable coComments:  yes (tried with no, same problem)
Show live preview: yes (preview works)
Avitars:  Wavatar (tried with none, same problem)
Moderate comments:  yes (tried with no, same problem)
Feb 21, 2009 at 6:59 PM
So previewing the comment works, but not saving the comment.  Do you see any JavaScript errors in your browser when you go to save the comment?  If you're using IE, an indication of an error may show up in the status bar of IE.  Same with Firefox.  Although with Firefox you can get more detailed information on any JavaScript errors in the Error Console (Tools -> Error Console).
Feb 21, 2009 at 10:12 PM
Thanks, I got your PM with the URL.  I think I see the problem.  The response coming back from the server is:

"You must enter your blog information into the extensions manager in the admin section"

See this discussion which talks about this.  It looks like it's a problem with an extension ... that you can either disable or enter the information into the extension it's looking for.
Feb 21, 2009 at 11:33 PM
OK.  To confirm what the other discussion indicated, as soon as I disable Askimet, the comment works instantly.

So given that the issue now is the Akismet Extension... I'm confused.  I did already have the AkismetExtension settings configured with the API key and Blog URL entered.  The API key came from my WordPress site logon... I have a logon there (but no Blog) expressly for the purpose of getting the free personal use API key.  I just logged in to confirm that key and it is correct.  Is there somewhere I need to configure what my Blog URL is on WordPress Profile or so that it will accept the connection coming from my blog???

Feb 21, 2009 at 11:34 PM
Before, I entered the URL without http://
I enter with

And it works!  :)