Rating does not work

Feb 22, 2009 at 9:27 AM

I installed the change set 25288 and the rating system does not work. When I click to rate, I get a HTTP Error 404.0 - Not Found page.

Is there soemething I could do without re-compiling as currently i'm not in a position to install VS 2008 or Express.


Feb 22, 2009 at 11:07 AM
I am ready to launch my blog and everything is working perfectly. The only thing stopping me is the rating system not working. I would appreciate if someone could give me a quick fix to this problem ASAP.

Many thanks

Feb 22, 2009 at 5:41 PM
That's a new, small problem in changeset 25288.  See this for a solution.
Feb 23, 2009 at 7:29 AM
Thanks! It worked. Just wanted to clarify something. Are the ratings now rounded off e.g 3.5 would read as 4? If so why did the developers opt for that. I have e.g 3.5 stars showing but it reads as Currently rated 4 by 2 people.

Anyway that's really not a big issue. I can live with it.

Thanks anyway for your help.

Best regards,

Feb 23, 2009 at 9:43 AM
Edited Feb 23, 2009 at 10:00 AM
Finally i have moved from VS2005 en 2000 to Visual Studio 2008 Espress on XP, and downloaded the svn source code in order to update my own blog to the latest engine version,. and i am testing it in an virtual machine before deploying it to the phisical one.

Thanks to BenAmada for his tip on ratings but it doesn't work for me, and: What has happend to the tooltip over the rating stars that we could see in BE i liked it a lot.

Greetings from Spain!!!

P.d.: Visit my web at: http://www.gunner.es

Feb 23, 2009 at 5:19 PM
sayedwasim: You're right about the rounding to a whole number.  I just added a comment in that same issue about how the old behavior (e.g. 3.5 instead of 4) can be restored.
Feb 23, 2009 at 5:57 PM
gunner: I added a comment in that issue on getting the old tooltips back in there.  There's just a single line of code needed to add to blog.js, which you could add in your blog.js file.  See the issue comments for that line of code.
Feb 23, 2009 at 8:55 PM

Ben : your fix solves resource not found exception, but now I get broken link : http://www.mydomain.com/myblog/rate/5. This worked fine in previous blog java script versions which used javascript:void(Rate('GUID', 5). 

Feb 23, 2009 at 9:02 PM
mvincic: That's a new problem introduced in changeset 25288.  If you haven't noticed, see the main topic brought up in this issue - a solution is provided.  It looks like John Dyer is going to fix it pretty soon in an upcoming build.
Feb 24, 2009 at 7:10 AM
Thanks Ben everything works fine for me now. Really appreciate!