including slide.show 2

Topics: ASP.NET 2.0
Feb 23, 2009 at 7:38 PM
Hi,
I was wondering if anyone has successfully included the slide.show 2 control on a seperate page or post?

I'm including it in a usercontrol as such:
[usercontrol:~/slide.ascx]

and the ascx usercontrol contains the following:

<object type="application/x-silverlight-2" data="data:application/x-silverlight-2," width="100%" height="100%">
     <param name="background" value="black" />
     <param name="source" value="Slideshow/Vertigo.SlideShow.xap" />
     <param name="initParams" value="ConfigurationProvider=DarkTheme,DataProvider=XmlDataProvider;Path=SlideShow.axd"/>
     <param name="initParams" value="ConfigurationProvider=LightTheme,DataProvider=FlickrDataProvider;UserName=[disneyleffe];ApiKey=[b45329018eafdf2a4f89ebf6fb2bf47a]" />
     <div style="width:100%; height:100%;text-align:center">
          <a href="http://go.microsoft.com/fwlink/?LinkID=124807" style="text-decoration: none;"><img src="http://go.microsoft.com/fwlink/?LinkId=108181" alt="Get Microsoft Silverlight" style="border-style: none" /></a>
          <br />Microsoft Sliverlight is required to properly run this site.</div>
</object>

But when viewing the page nothing is showing.
Mar 11, 2009 at 2:36 AM
Edited Oct 26, 2009 at 5:41 AM


the things below maybe can help you

  •  On your code , 2 configurationprovider and 2 data provider is true?

 <param name="initParams" value="ConfigurationProvider=DarkTheme,DataProvider=XmlDataProvider;Path=SlideShow.axd"/>
<param name="initParams" value="ConfigurationProvider=LightTheme,DataProvider=FlickrDataProvider;UserName=[disneyleffe];ApiKey=

 Their Flickr sample like below

<object type="application/x-silverlight-2" data="data:application/x-silverlight-2," width="640" height="480"><param name="background" value="#fff" /><param name="source" value="../ClientBin/Vertigo.SlideShow.xap" /><param name="initParams" value="ConfigurationProvider=LightTheme,DataProvider=FlickrDataProvider;UserName=tonysoko;ApiKey=b45329018eafdf2a4f89ebf6fb2bf47a" /><a href="http://go.microsoft.com/fwlink/?LinkID=124807" style="text-decoration: none;"><img src="http://go.microsoft.com/fwlink/?LinkId=108181" alt="Get Microsoft Silverlight" style="border-style: none" /></a></object>

  • I am not sure but i guess FireFox got problem with width="100%" height="100%", i changed them to values like width="640" height="480"
  • I used firefox's firebug extension to track what is going on, it can be helpfull for you too.

Regards,