IIS7 js.axd returning blank page

Topics: ASP.NET 2.0
Mar 1, 2009 at 9:03 PM
I pulled the source from codeplex's svn connection, setup my local IIS7 on vista to have a site called vs-blogengine and hit it. It works fine.

Then, I upload that same code to mosso.com's hosting and the js.axd returns an empty document response. Here is my system.webServer section...

<

 

system.webServer>
<
validation validateIntegratedModeConfiguration="false" />
<
modules>
<
remove name="Profile" />
<remove name="AnonymousIdentification" />
<
remove name="ScriptModule" />
<
add name="WwwSubDomainModule" preCondition="managedHandler" type="BlogEngine.Core.Web.HttpModules.WwwSubDomainModule, BlogEngine.Core, Version=1.4.5.14, Culture=neutral" />
<
add name="UrlRewrite" preCondition="managedHandler" type="BlogEngine.Core.Web.HttpModules.UrlRewrite, BlogEngine.Core, Version=1.4.5.14, Culture=neutral" />
<
add name="CompressionModule" preCondition="managedHandler" type="BlogEngine.Core.Web.HttpModules.CompressionModule, BlogEngine.Core, Version=1.4.5.14, Culture=neutral" />
<
add name="ReferrerModule" preCondition="managedHandler" type="BlogEngine.Core.Web.HttpModules.ReferrerModule, BlogEngine.Core, Version=1.4.5.14, Culture=neutral" />
<
add name="ScriptModule" preCondition="managedHandler" type="System.Web.Handlers.ScriptModule, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" />
</
modules>
<
handlers accessPolicy="Read, Write, Script, Execute">
<
remove name="WebServiceHandlerFactory-Integrated" />
<
remove name="ScriptHandlerFactory" />
<
remove name="ScriptHandlerFactoryAppServices" />
<
remove name="ScriptResource" />
<
remove name="PageHandlerFactory-Integrated" />

 

<

 

add name="ScriptHandlerFactory" verb="*" path="*.asmx" preCondition="integratedMode" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" />

 

<

 

add name="ScriptHandlerFactoryAppServices" verb="*" path="*_AppService.axd" preCondition="integratedMode" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" />

 

<

 

add name="ScriptResource" verb="GET,HEAD" path="ScriptResource.axd" preCondition="integratedMode" type="System.Web.Handlers.ScriptResourceHandler, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" />

 

<

 

add name="PageHandlerFactory-Integrated" verb="*" path="*.aspx" type="System.Web.UI.PageHandlerFactory, System.Web, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" resourceType="Unspecified" requireAccess="Script" preCondition="integratedMode" />

 

<

 

add name="HtmlFiles" verb="*" path="*.html" type="System.Web.StaticFileHandler, System.Web, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" resourceType="Unspecified" preCondition="" />

 

<

 

add name="FileHandler" verb="*" path="file.axd" type="BlogEngine.Core.Web.HttpHandlers.FileHandler, BlogEngine.Core, Version=1.4.5.14, Culture=neutral" resourceType="Unspecified" requireAccess="Script" preCondition="integratedMode,runtimeVersionv2.0" />

 

<

 

add name="ImageHandler" verb="*" path="image.axd" type="BlogEngine.Core.Web.HttpHandlers.ImageHandler, BlogEngine.Core, Version=1.4.5.14, Culture=neutral" resourceType="Unspecified" requireAccess="Script" preCondition="integratedMode,runtimeVersionv2.0" />

 

<

 

add name="Syndication" verb="*" path="syndication.axd" type="BlogEngine.Core.Web.HttpHandlers.SyndicationHandler, BlogEngine.Core, Version=1.4.5.14, Culture=neutral" resourceType="Unspecified" requireAccess="Script" preCondition="integratedMode,runtimeVersionv2.0" />

 

<

 

add name="Sitemap" verb="*" path="sitemap.axd" type="BlogEngine.Core.Web.HttpHandlers.SiteMap, BlogEngine.Core, Version=1.4.5.14, Culture=neutral" resourceType="Unspecified" requireAccess="Script" preCondition="integratedMode,runtimeVersionv2.0" />

 

<

 

add name="Trackback" verb="*" path="trackback.axd" type="BlogEngine.Core.Web.HttpHandlers.TrackbackHandler, BlogEngine.Core, Version=1.4.5.14, Culture=neutral" resourceType="Unspecified" requireAccess="Script" preCondition="integratedMode,runtimeVersionv2.0" />

 

<

 

add name="Pingback" verb="*" path="pingback.axd" type="BlogEngine.Core.Web.HttpHandlers.PingbackHandler, BlogEngine.Core, Version=1.4.5.14, Culture=neutral" resourceType="Unspecified" requireAccess="Script" preCondition="integratedMode,runtimeVersionv2.0" />

 

<

 

add name="OpenSearch" verb="*" path="opensearch.axd" type="BlogEngine.Core.Web.HttpHandlers.OpenSearchHandler, BlogEngine.Core, Version=1.4.5.14, Culture=neutral" resourceType="Unspecified" requireAccess="Script" preCondition="integratedMode,runtimeVersionv2.0" />

 

<

 

add name="MetaWeblog" verb="*" path="metaweblog.axd" type="BlogEngine.Core.API.MetaWeblog.MetaWeblogHandler, BlogEngine.Core, Version=1.4.5.14, Culture=neutral" resourceType="Unspecified" requireAccess="Script" preCondition="integratedMode,runtimeVersionv2.0" />

 

<

 

add name="RSD" verb="*" path="rsd.axd" type="BlogEngine.Core.Web.HttpHandlers.RsdHandler, BlogEngine.Core, Version=1.4.5.14, Culture=neutral" resourceType="Unspecified" requireAccess="Script" preCondition="integratedMode,runtimeVersionv2.0" />

 

<

 

add name="CssHandler" verb="*" path="css.axd" type="BlogEngine.Core.Web.HttpHandlers.CssHandler, BlogEngine.Core, Version=1.4.5.14, Culture=neutral" resourceType="Unspecified" requireAccess="Script" preCondition="integratedMode,runtimeVersionv2.0" />

 

<

 

add name="Javascript" verb="*" path="js.axd" type="BlogEngine.Core.Web.HttpHandlers.JavaScriptHandler, BlogEngine.Core, Version=1.4.5.14, Culture=neutral" resourceType="Unspecified" requireAccess="Script" preCondition="integratedMode,runtimeVersionv2.0" />

 

<

 

add name="Rating" verb="*" path="rating.axd" type="BlogEngine.Core.Web.HttpHandlers.RatingHandler, BlogEngine.Core, Version=1.4.5.14, Culture=neutral" resourceType="Unspecified" requireAccess="Script" preCondition="integratedMode,runtimeVersionv2.0" />

 

<

 

add name="Opml" verb="*" path="opml.axd" type="BlogEngine.Core.Web.HttpHandlers.OpmlHandler, BlogEngine.Core, Version=1.4.5.14, Culture=neutral" resourceType="Unspecified" requireAccess="Script" preCondition="integratedMode,runtimeVersionv2.0" />

 

<

 

add name="BlogML" verb="*" path="blogml.axd" type="BlogEngine.Core.Web.HttpHandlers.BlogMLExportHandler, BlogEngine.Core, Version=1.4.5.14, Culture=neutral" resourceType="Unspecified" requireAccess="Script" preCondition="integratedMode,runtimeVersionv2.0" />

 

<

 

add name="SIOC" verb="*" path="sioc.axd" type="BlogEngine.Core.Web.HttpHandlers.Sioc, BlogEngine.Core, Version=1.4.5.14, Culture=neutral" resourceType="Unspecified" requireAccess="Script" preCondition="integratedMode,runtimeVersionv2.0" />

 

<

 

add name="Apml" verb="*" path="apml.axd" type="BlogEngine.Core.Web.HttpHandlers.Apml, BlogEngine.Core, Version=1.4.5.14, Culture=neutral" resourceType="Unspecified" requireAccess="Script" preCondition="integratedMode,runtimeVersionv2.0" />

 

<

 

add name="Foaf" verb="*" path="foaf*.axd" type="BlogEngine.Core.Web.HttpHandlers.Foaf, BlogEngine.Core, Version=1.4.5.14, Culture=neutral" resourceType="Unspecified" requireAccess="Script" preCondition="integratedMode,runtimeVersionv2.0" />

 

</

 

handlers>

 

<

 

staticContent>
<
clientCache cacheControlMode="DisableCache" />
</
staticContent>

 

<

 

security>

 

<

 

authentication>

 

<

 

basicAuthentication enabled="false" />

 

</

 

authentication>

 

</

 

security>

 

<

 

defaultDocument>

 

<

 

files>

 

<

 

clear />

 

<

 

add value="default.aspx" />

 

</

 

files>

 

</

 

defaultDocument>

 

<

 

httpRedirect enabled="false">

 

<

 

clear />

 

</

 

httpRedirect>

 

</

 

system.webServer>


Any ideas???