Customize template.

Topics: ASP.NET 2.0, Themes
Mar 5, 2009 at 11:24 PM
I am customizing the template "GreyShadow".

Changed the header so that instead of displaying the title and description show a picture.

Until then fine, but when I create a new post the image is not loaded.
Someone had this problem? If yes, to solve? how?

Coordinator
Mar 5, 2009 at 11:58 PM
What is the "src" of your <img>?  You may need to add a slash in front of the src or make another adjustment so the image path is valid when the current URL is a sub-folder.
Mar 6, 2009 at 12:42 AM
into the site.master i imput the code below, but when i creat a new post the folder has creat with the date and the month this post.. and this page not show the image on the header

 <body>
    <div id="wrapper">
 
        <div id="header">
            <table width="940" border="0" align="center" cellpadding="0" cellspacing="0" align="center">
                <tr>
                    <td colspan="3" align="center"><img src="images/base_branca_05.jpg" width="940" height="89" /></td>
                </tr>
            </table>
            <!--h1><a href="<%=Utils.AbsoluteWebRoot %>"><%=BlogSettings.Instance.Name %></a></h1-->
            <!--h2><%=BlogSettings.Instance.Description %></h2-->
        </div>

 

 

 

Coordinator
Mar 6, 2009 at 2:05 AM
Try changing your <img> tag to the following (I added a slash before images):

<img src="/images/base_branca_05.jpg" width="940" height="89" />
Coordinator
Mar 6, 2009 at 3:45 AM
And if that doesn't work (because your blog is installed in an application off of a website -- rather than in the root of the website), then you can either put the folder name in front, like:

<img src="/FolderName/images/base_branca_05.jpg" width="940" height="89" />

... or the following should do the trick:

<img runat="server" src="~/images/base_branca_05.jpg" width="940" height="89" />
Mar 6, 2009 at 3:57 AM
Really have much to learn on. Net But do not give so easy! Once again I thank you. the trick solved my problem.