Error when trying to delete or edit posting (using filesystem) and / or SQL Setup behaving badly.

Topics: ASP.NET 2.0, Business Logic Layer, Themes
Mar 21, 2009 at 4:16 PM
Hi,

I have just installed blogengine on an existing site and am experiencing some bizzare behaviour.

If I try to delete or edit a posting, the attempt returns the error shown at them bottom.
The interesting thing in the case of the edit, is that the edit is made and changes are saved. However the error comes up. This happens no matter what theme I am using. (built in themes as well as custom themes).

I have also tried to run the blog using SQL server. This again seems to have issues as it doesn't seem to recognise the style.css inside the root of the theme.

The build I am using is the latest and I have successfully installed it on servers before without any issue. However this site seems to be a constant aboration. ANY clues as to how to fix this would be appreciated. In the past SQL has always been reliable, but I think filesystem will work if I can get rid of hte error. and allow deletes to occour.


TIA

Rob



The resource cannot be found.

Description: HTTP 404. The resource you are looking for (or one of its dependencies) could have been removed, had its name changed, or is temporarily unavailable.  Please review the following URL and make sure that it is spelled correctly.

Requested URL: /news/blog/post/A-Brand-new-Posting.aspx


Version Information: Microsoft .NET Framework Version:2.0.50727.3074; ASP.NET Version:2.0.50727.3074
Mar 21, 2009 at 4:36 PM
Well I still have no idea as to what the issue with SQL is, but the filesystem is now working thanks to the following post.
http://www.codeplex.com/blogengine/Thread/View.aspx?ThreadId=42541

Interestingly the first fix (replace the entire section did work for me. - I had tried to jump directly to the bottom first and it failed.)

If anyone has insights as to what the issue with sql is, and how to fix the SQL based web.config I would love to know.


Thanks..

Rob


Coordinator
Mar 21, 2009 at 6:12 PM
When you switch to using the DbBlogProvider to store data in SQL Server, what error are you getting now?  It doesn't seem like the blog provider would have any impact in whether style.css comes up in the browser.
Mar 21, 2009 at 8:15 PM
Edited Mar 21, 2009 at 8:20 PM
That is the most bizzare part. No error. Just no css. Everything shows up in black serif text on a white background with whatever formatting is applied to the html.. i.e. minimal

The config is just the default one in the "setup folder" for sqlserver, with the connection string for the blogengine changed. It worked fine when I hosted it on my windows 2003 box.. So I wonder if i need to add some sections there also.

The Server seems to be an iis7 and hosts multiple sites. The DB is SQL2008, but i can't see any issues the version of sql would make to this.

Rob




Coordinator
Mar 21, 2009 at 8:28 PM
When you're having this problem, if you right-click in your browser and do a 'View Source', in the <head> section, you'll find a <link> tag for the style.css file.  It'll either be a direct link to style.css or a link to the CSS.axd file that serves the styles.

---- Example direct link to style.css ----
<link rel="stylesheet" href="themes/Standard/style.css" type="text/css" />

---- Example link to CSS.axd ----
<link rel="stylesheet" href="/blog/themes/Standard/css.axd?name=style.css&amp;v=1.4.5" type="text/css" />

Look for that link.  When you find it, try navigating to that URL directly in your browser.  So you'll either end up navigating to something like:

http://localhost/blog/themes/Standard/style.css
  --- or ---
http://localhost/blog/themes/Standard/css.axd?name=style.css&v=1.4.5

When you navigate to the URL directly, you'll probably get an error message which will give us more information.
Mar 21, 2009 at 9:47 PM
Edited Mar 21, 2009 at 9:49 PM
Im not sure what I am looking for.. My guess is this line

<link rel="stylesheet" href="/events/themes/Standard/css.axd?name=style.css&amp;v=1.4.5.0" type="text/css" />

Relative from the root of the blog. /themes/standard/ is probably correct. I am wondering if the /events before the themes might be causing the problem as it could be trying to send it one level further up the tree.. 

(the blog root is in the events directory of my site.)

Rob
Coordinator
Mar 21, 2009 at 10:48 PM
So if you the URL to your blog's front page is:

http://localhost/events/

Then, in your browser try navigating directly to:

http://localhost/events/themes/Standard/css.axd?name=style.css&amp;v=1.4.5.0

And see what happens.  You might need to changeout the 'localhost' part to whatever you have.