Master Page Error

Mar 30, 2009 at 7:15 PM
Edited Mar 30, 2009 at 7:18 PM

Hi Guy's,

I have just downloaded the BlogEngine.Web and have it accessable from the web but I can't edit the default.aspx page using Visual Web Developer Express Edition because of an error when I go to the design page:

Master Page Error

The page has controls that require a master page reference, but none is specified

correct the error in code view.


Has anyone seen this error before.

Thanks in advance.

Coordinator
Mar 30, 2009 at 7:44 PM
This message shows up even in Visual Studio (non-express).  You should be able to edit the page in the Source view -- at least that's what I've always done.

Because BE support dynamic themes, the master page for all these content pages isn't set until runtime.  The Visual Studio designer must not like this.

You could manually add a MasterPageFile attribute in the <%@ Page %> directive of the page you want to edit, like this:

MasterPageFile="~/themes/Standard/site.master"

This would allow you to use the designer in VS.  If you choose a different theme in the control panel, BE will still override that master page at runtime.
Mar 30, 2009 at 10:47 PM
Thanks Ben,

I can't see the wiki now, run time error, I'm having trouble taking the read only off the app_data folder 




Coordinator
Mar 30, 2009 at 10:53 PM
I just sent an email off to see about the documentation wiki.

Have you enabled "write" permissions on the App_Data folder?  That's probably most important.  You would want to give "write" permissions to the ASPNET user.  On Windows Server 2003, it's usually the Network Service account you want to give write permissions to.

I too can't fully remove the read-only attribute from all the folders/files in BE.  So I wouldn't be overly concerned about the read-only attribute.
Mar 30, 2009 at 11:19 PM
Thanks again Ben,

that's what I was missing.