Error in Purge All

Topics: ASP.NET 2.0
Feb 4, 2014 at 8:38 AM
Hi,
I have just upgraded my BlogEngine.net blog to version 2.9 and 2.9.1.
I have a problem: in the dashboard page, the 'Purge All' for the Trash doesn't work.
I have the same problem in the popup showing the Logs, the Purge command doesn't work.

I have write permissions on the App_Data folder, in fact I can create and delete new posts.

What should I do to get the Purge functionality working correctly?

Thank you, Damiano
Feb 5, 2014 at 3:32 PM
Hi,
I have verified that:
  • I can't purge all the trash
  • I can't purge a single item in the trash
  • I can't publish a draft article
I have give to the /App_Data and /api folder all the permissions (read, write, delete).

The website is hosted in arvixe.com.

Can you please help me?

Thank you, Damiano
Coordinator
Feb 5, 2014 at 4:01 PM
Can you post/update/delete anything? Like category, new user? Or your issue specific to trash/draft and everything else works fine?
Feb 5, 2014 at 4:23 PM
Hi,
it seems I can't delete anything. At least I can't delete draft posts.
Also I can publish a draft posts.

Also: I have been able to create a new user, but now I can't delete it.

I have found this article: http://forum.arvixe.com/smf/programming-questions-tutorials/web-api-not-working-for-delete/
But even after having removed the WebDAV module and handler, I'm still not able to delete posts or user.

Do you have any idea?
Arvixe has confirmed me I am correctly using .NET 4.5 and MVC is installed.

Thank you, Curia Damiano
Coordinator
Feb 5, 2014 at 4:31 PM
Looks like same exact issue as here: https://blogengine.codeplex.com/discussions/528599, with put/delete methods not allowed in IIS.
Coordinator
Feb 5, 2014 at 5:12 PM
Not really a help but - I just went to Arvixe control panel, created virtual directory and uploaded 2.9 (web) to this directory as is, no changes. It threw "not allowed" at me when I tried to access web page, so I went to "virtual directory properties" in the same control panel and selected "enable write permissions". Now post/update/delete works for everything I checked so far (http://dnbegallery.org/be29).
Feb 6, 2014 at 8:17 AM
Hi rtur,
I suspect too that the problem is that it's not possible to issue PUT and DELETE requests.
Your first link described exactly my problem.

I have tried your suggestion, I have BE 2.9.1 installed in my root folder, so I have given complete rights (write, delete) to the wwwroot folder (without inheriting permissions this time) and still no luck. Remember the folders App_Data and _api already have write & delete permissions.

I've tried to give permissions to my root folder (so outside wwwroot) but again no luck.

I'll try to ask arvixe to give me PUT and DELETE verbs, but I think this should be done via web.config in new IIS.

If you have any ideas pls help me, and from my side if I'll be able to solve it, I'll post my resolution.

Thanks, Damiano
Feb 6, 2014 at 9:54 AM
Found a very similar issue here: http://forum.arvixe.com/smf/general/http-put-and-delete-with-asp-net/
Written Arivixe to do the same for me, waiting from reply.
I'm only suprised this settings doesn't come from web.config now.
Regards, Damiano
Feb 6, 2014 at 4:09 PM
Edited Feb 6, 2014 at 6:05 PM
Hi,

I am currently using BlogEngine.NET 2.9.1.4

It is giving me a require "Authorization" pop-up window that windows uses when I try to delete any thing from the dashboard.

Enter BE login info but that does not work.

Then get error "Error Purging"

I can delete posts, users and etc ok.

Just issue with dashboard items delete.

Update: Got it all working by giving the entire folder /app_data Read,Write, and Delete permissions.
Feb 6, 2014 at 4:26 PM
Hi,
Arvixe has replied me.

1) I need to enable IIS Remote Management in control panel, as described in http://blog.arvixe.com/enable-remote-management-in-websitepanel/
2) I'll need to connect to IIS remotely as described in http://blog.arvixe.com/how-to-use-internet-information-services-iis-7-manager-to-connect-remotely-to-your-website/
3) Finally I'll be able to enable the PUT and DELETE verbs

I'll try this evening.

For sure, in the deploy/upgrade instructions, I would add this as a requirement to be checked.
I don't think all providers would enable IIS remote mgmt, luckly Arvixe yes.

Regards, Damiano
Coordinator
Feb 6, 2014 at 5:12 PM
Not quite sure what's going on with Arvixe, as I mentioned I was able to run 2.9.1 out of the box on my Arvixe account just fine, no PUT/DELETE changes required. Only guess would be they block it on root and allow on sub-sites, because I created new site in sub-folder and ran from there. Seems web API still too new and scary for some :) Accidentally, Scott Hanselman published post today describing workaround for this same issue, which I'm not sure I like but it shows it is rather common for admins to block PUT/DELETE for no good reason, which is sad.
Feb 6, 2014 at 10:22 PM
Edited Feb 6, 2014 at 10:25 PM
Hi All,

As Rtur, had pointed out you do not need to do any additional steps to get BE 2.9.1 to work out of the box on a Arvixe server.

If you are using Arvixe you should have Windows 2012 server already since they upgraded or replaced all of their servers, to be on the safe side double check your website and make sure it is Windows 2012.

Go to Control Panel --> Website --> At the very top would be your server information.

If you are on Windows 2012, double check that you have in Extensions ASP 4.0 (4.5) selected with integrated app_pool.

-------------------------------------------Note--------------------------------------------------------------------
If you are still on Windows 2008 server you need to contact Arixe to move you to one of their Windows 2012 servers, they are moving all servers to
Windows 2012 any way, they just might not had gotten to you yet.

As of around June 2014 Microsoft support for Windows 2008 will be discontinued that is the reason for Arixe to move or upgrade all servers to Windows 2012.

In file manager go to folder /app_data select the "lock" icon and select Read,Write, Delete and on the far right select to apply this settings to all of your
folders within the /app_data folder like /app_data/posts and etc.

Do the same for the /api folder.

After you had done that it should be working for you.

I have the Reseller Plan on Arvixe and got BE 2.9.1.4 to work out of the box "as-is" just by doing those two changes.

Took about 2 mins to fix actually got it fixed right after I submitted my first post in this thread :)

The other settings if you are on Windows 2012 are not needed, no need for IIS Remote management editing and etc.

All that does any way is add those settings to your web.config file :)

It just creates the settings you need for web.config and copies it over to your web.config for you nothing is changed server side just your web.config.


I had been an Arvixe customer for over 3 years now and they are the best Web hosting company in the world :)

If you have any questions about this I can help.


You can reply here or contact me directly at:


kbdavis07@yahoo.com Have a Great Day!



Brian Davis
http://bloggersonline.com
Feb 7, 2014 at 5:32 PM
Hi,
I have tried for the n-th time and this time everything worked perfectly.
I still don't know the reason why it is working, but I have simply given write rights to the App_Data folder (no _api) and I have not modified the BE web.config.
That's all, I really don't know what has Arvixe done on the servers and why it is working now...
Thanks for your support, Damiano
Feb 10, 2014 at 8:47 PM
Hi,
after two days the site doesn't work anymore.
I have written arvixe but still no answers.
So I've asked them to upgrade to Windows 2012 (like described in previous post) but again no answer.

Simply Arvixe doesn't give support for this http PUT / DELETE problem.

I underline the web.config is right, the permissions were right, simply there is something in their environemnt that changes from day to day and anyway makes the site not to work correctly.

I am an unsatisfied user and I will change provider.

Only, I ask you if you could consider alternatives in development not using REST APIs, because this could be an issue...

Thank you, Damiano
Feb 10, 2014 at 10:08 PM
Hi Dax1974,

You can give us a try

http://bloggersonline.com

We have Windows 2012 and have BE 2.9 working great!

You can test drive it yourself by creating your own free test blog here:
http://demo.bloggersonline.com/Account/create-blog.aspx

After test driving it go ahead and sign up for our service :)

Our Basic Web hosting is only $0.99 per month and the lowest price you will find in the world for Windows Hosting.

Plus you get BE Expert help too :)

Also offer free install of BE 2.9 you will be up and running in about 10 mins or less.

If you have any questions please contact me directly at:

kbdavis07@yahoo.com Have a great day!

Brian Davis
Http://bloggersonline.com
May 29, 2014 at 3:55 PM
I had this problem on an arvixe 2012 server and it turns out the permissions were slightly off. For the App_Data folder, make sure NETWORK SERVICE has write permissions (app compilation), and then your pool account (usually the websites name) has BOTH Write and Delete.
May 30, 2014 at 9:50 AM
Well,
I've opened many tickets with Arvixe and I didn't get any reply.
Sincerly I hope the support team will be fired, because I got no support.
Now I am with BloggersEngine (same platform, but a single very helpful guy supporting everything) and I'm very happy.
Regards, D.