Verb PUT does not work, unable to save anything in 2.9

Topics: ASP.NET 2.0, Themes
Feb 16, 2014 at 5:20 PM
Hi,

I've been struggling with this problem for a week now, and I'm starting to feel desperate!

I upgraded my blog to BE 2.9 (it's really sweet!). At first everything seemed fine. I could create posts, but then I discovered that I could not change and save them. Delete also worked fine. When I tried to save things in the admin settings, same problem.

I found this forum topic: http://blogengine.codeplex.com/discussions/528599

I have exactly the same problem, although I'm not able to solve it. I've tried everything I can think of, but nothing helps. I have not full control of the server, since I'm using host company.

I've also tried the stuff in this post: http://stackoverflow.com/questions/10906411/asp-net-web-api-put-delete-verbs-not-allowed-iis-8

No luck.

This is what a successful post looks like:

Image

A second later when saving, the put:

Image

As far as I know, I (or the service provider) meets all requirements, .NET 4.5, Full trust, writable folder. It's so strange, everything else works, delete, save... It would be a shame if I have to rollback to the old 2.8 now with the new version so great in all other aspects. I really hope someone could help me figuring this out!
Feb 17, 2014 at 12:20 AM
Hi kaze72,

Look at the very bottom of your screenshot:

Response Headers

Server: Microsoft-IIS/7.5
X-App-Hosting: pool = classic

Also IIS 7.5 means more likely on a Windows 2008 Server.

You need Windows 2012 Server in Integrated mode to work "as-is".

Otherwise your hosting provider will have to make some changes on their end to get Web API to work correctly.
Feb 17, 2014 at 6:53 AM
Edited Feb 17, 2014 at 7:24 AM
-When you save changes in setting->BASICS for name and description of your blog, it will not change in be 2.9 version.

-Just choose standard in Set as mobile option, and click on save.

-So you must choose also mobile theme, apart from Set as current theme option.

It work for me.
Feb 17, 2014 at 7:31 AM
Thanks, I've contacted my service provider, hopefully they are able to do some reconfiguring.

zealgeeks: I also had the problem you describe. I solved it, the other issue is something else unfortunately. Thanks for you answer.
Mar 2, 2014 at 10:48 AM
Edited Mar 2, 2014 at 10:49 AM
It is a month that I combat with this error.. I CANNOT EDIT a post due this PUT error

IIS 8.0 on windows server 2012; I own the server, so I can do all the modifications I want.

I added PUT and DELETE to the verb allowed to ExtensionLessUrlHandler (to all the 3 versions: Integrated, isapi32/64); the appPool is running in integrated mode4.0, the appPool user has full right to app_data folder, I removed webdav module...
I did ALL what I read about this issue, but I still unable to save a post edit (only new post).

What can I do to debug better this error? I want to be sure that it is related to "verb not allowed" issue and nothing else...

Thanks

Image