BlogEngine able to add new content but unable to update any setting in admin panel.

Topics: ASP.NET 2.0
Mar 3, 2014 at 6:19 AM
I am able to add new content.. but i got an "update failed" error when i tried to update any setting in my admin panel.I am unable to add new extensions , widgets etc
I have host blogengine using (arvixe) hosting plan. Please reply as soon as possible .
Mar 3, 2014 at 6:33 AM
Edited Mar 3, 2014 at 6:34 AM
Hi Amitbaghel,

We at also uses Arvixe for our server.

Screenshot in Website Panel of the Settings you need:

We have over 7 installs of BE 2.9 and they work with these settings.
Mar 3, 2014 at 6:38 AM
Thanks for your valuable supports
I will check the details and try to replicate on the server

Thanks one again i will come back to up if problem persists
Mar 3, 2014 at 6:42 AM

My Server Info is Below
Server Info
Microsoft Windows Server 2012 R2 Standard

Write Permission Enabled is check already
but problem is still there
Mar 3, 2014 at 6:53 AM
Hi Amitbaghel,

Following the screenshot provided should solve your issue.

If not check your log from Dashboard in Admin.

It will tell you if you are having write permission issues.
Mar 4, 2014 at 10:34 AM
Thanks davis.

Thanks alot for helping me.
Now its working.. :-)

It was just an small issue.. my api was not loaded correctly. I reupload my files on ftp server by making a zip file.. And all done.
Thanks Once again davis .
Mar 4, 2014 at 10:58 AM
Hi Amitbaghel,

Thanks for your comment.

For others this shows the importance of Firebug!

Solved Amitbaghel problem by using Firebug and seeing when doing any admin functions keep getting 404 Error for website/api/SomeAction

Also it is best to download locally unzip BE, then make sure it works locally and etc, then zip up the folder /BlogEngine.NET then upload the zip folder
not ftping the folder and files one by one.

Once zip folder is on server unzip it there.

That way prevents missing files or folders and also much faster.

Better method if you use Visual Studio is Web Deploy!
Mar 8, 2014 at 8:04 AM
Hi davis ,

Thanks for your valuable comments and helps now i stuck into new problem :-(

When i post a content and publish it then i am able to see these post when i am login using admin account. but when i sign out and landed on the home page i am unable to see my latest added post. What is the problem here ?