Updating my blog from my iPhone

Topics: Themes
Apr 18, 2009 at 12:02 PM
Hi there

I have a blog running blogengine.net which I love. I'm happy that my iPhone browser displays the blog as it is on the net (i.e. not a mobile theme) but the ONLY problem that I have is that i can't update or add a new post from my iPhone browser.

I can log in and get to the Add Entry page but the browser doesn't recognise the text fields as editable so i can't type anything. I've tried using the Blogwriter iPhone app but can't get it to log in.

Everything else works great on the iPhone, I love it. So conected everywhere. But I'm off on a Euro road trip this summer and want to be able to blog it mobile.

Any ideas?

Thanks
Mark
Coordinator
Apr 18, 2009 at 11:12 PM
I don't have an iPhone, but do know someone who has been able to create blog entries with his iPhone.

Which version of BE are you running?  Between 1.4.5 and 1.5, BE was updated with the newest version of the tinyMCE WYSIWYG editor.  The one in BE 1.4.5 is much older than the new one.

Version 1.5 of BE was just released last week.

The friend I mentioned is using a version of BE with the newer WYSIWYG editor.  I'm not entirely sure if the newer version will solve this issue, but there's a chance it will.  You could try the demo page of the very latest tinyMCE editor at the link below to see if you can type in the editor field.

http://tinymce.moxiecode.com/examples/full.php

By the way, are the fields you can't type in just the main WYSIWYG editor?  Or can you also not type in the other fields too? (Title, slug, description, etc)
Apr 24, 2009 at 2:59 PM
Hi Ben,

I am planning to use BE1.5 and i have a iphone which i intend to use for blogging.

Before taking the plunge, i wanted to test if i can enter text using the tinymce editor and so followed the link that you provided.

http://tinymce.moxiecode.com/examples/full.php

I am not able to enter text into the editor on that page.

Any idea what i need to do?

Thanks,
Suresh

Apr 27, 2009 at 10:41 AM
Hi guys

I've tried that new TinyMCE too and it won't let me update from my iPhone!

It's the only thing I can't get to from my phone now and it's actually making me think I might have to switch blog applications to maybe WordPress or something more usable from the iPhone!

Mark
Coordinator
Apr 28, 2009 at 12:11 AM
emtwo: Are you using a generation 1 or 2 iPhone?  Just curious and it probably doesn't make a difference.  I don't know anything about the iPhone, but do have a friend who has a generation 2 iPhone.  Next time I meet him, I'll try using the tinyMce editor from his iPhone.

The other person I mentioned has an iPhone (not sure which generation), and he is able to type into the new version of tinyMce.  He never mentioned any problems, so I imagined it just worked.

Are you using the Safari browser on the iPhone or some other app when trying to compose a post in tinyMce?  I think with the built-in Safari browser, it's supposed to function like a normal browser.

Also, did you check to see if you could type into any of the other fields on the Add Entry tab -- such as the Title, Slug, Description, etc.?
Apr 28, 2009 at 8:38 AM
I have a gen 2 16Gb iPhone and can confirm it does not work with BE. You can log in and click on add post and the editor loads, but when you click on it, the iPhone keyboard does not appear. It's as if it doesn't know the editor is a text field or something.

I was using the default Safari browser
Apr 28, 2009 at 1:00 PM
I got in touch with developers at TinyMce through their forums and explained what is happening. I was advised that it has to be taken up with Apple and that they cannot do anything about this issue. Now, i am not sure whether it is a issue with the browser on iPhone or TinyMce is just trying to escape and put the blame on Apple.

Any way, i now have serious thoughts whether to look at alternatives to BE or wait for an update.

Thanks,
Suresh
Apr 28, 2009 at 1:02 PM
What happens if you select raw html mode in the editor? I haven't tried it
Coordinator
May 17, 2009 at 4:37 AM

I had a chance to use a friend's iPhone the other day.  The keyboard wouldn't come up when trying to type in the WYSIWYG editor, but the keyboard did come up when clicking the 'HTML' toolbar icon to put in straight text.  The raw HTML mode should also work.  In both these cases, the box is just a plain textarea field.

Jan 11, 2010 at 3:10 PM

Has anyone been able to come up with a fix for this?? I noticed no one has replied since last May.

I am also having the same problem. I have the latest blog version and newest 3GS iPhone.

 

Coordinator
Jan 11, 2010 at 3:13 PM

You can try this mobile theme with publishing from iPhone/iPod functionality.