anybody got recaptcha working with ???

Topics: Controls
Apr 1, 2014 at 8:51 PM
Signed up for recaptcha account - entered my public/private keys in the settings screen and checked the enabled checkbox.

Now what? I don't see captcha on contact page. I don't see captcha on comment page. I don't see captcha anywhere.

What am I missing?
Apr 1, 2014 at 9:51 PM
Edited Apr 1, 2014 at 9:53 PM
Hi Figmo,

You need to use the updated version of the recaptcha:

The recaptcha you are currently using might be using the old API address before Google Took it over.

You can double check by using FireBug and if you see this error:

NetworkError: 404 Not Found -

Or by searching the Recaptcha.cs file for the old api URL.

To fix:

If you want you can do a search and replace and that would also solve the issue:

Search For <--- Old

Replace with <--- New

Or just upload the files in the Recaptcha Folder located below:

Into your Recaptcha folder.

That should do it!

Have a great day!

Brian Davis

Apr 2, 2014 at 2:12 AM
Thank you for the reply. 2.9.1 is the current version available for download (and the one I'm working with). So it would be odd that the recaptcha would be out of date in there.

Anyway - I have the web version - not the source version. Do I need to rebuild the project to apply the changes you are talking about?
Apr 2, 2014 at 2:43 AM
Hi Figmo,

No rebuild needed just do a search and replace, or upload the new version.

It was fixed with so don't know why it is not working with 2.9.1

Look at your file RecaptchaControl.cs and see if it still contains the old URL?

Search For <--- Old

Should be around line #558

886768aa0003 by rtur (1 download) Dec 8, 2013 6:51 PM

Recaptcha broken API script link updated (

File Difference:

If you have the new API then you need to troubleshot with firebug.

That will tell you if you are missing anything.
Apr 6, 2014 at 7:17 AM

I have got the latest build and the latest api for recaptcha however it does not work on Azure. Any idea what can be wrong?