This project is read-only.

Website too slow after BE 1.5 upgrade?

Topics: ASP.NET 2.0, Themes
Apr 24, 2009 at 12:55 AM
Greetings and hello readers and BlogEngine team.

I'm writing to notify my website is runing very slow after the BE 1.5 upgrade. I upgraded from 1.4.5

Please check out the site at

The problem is, when you click on the navigation link on the top, there is a phenomenal delay, before any page loads up. I can't figure out what is going on. It does not matter how big or small the page is. My "Biography" page, and the "contact" page are both slow.

This problem did not happen on my previous 1.4.5 issue. I did change the banner image, though, but that should not be a problem.

This site is running on IIS 7, on .NET 3.5 SP1 and using SQL Server 2005.

Can someone help please?

Pinaki (DJ Pippins)

Apr 28, 2009 at 11:08 AM
Well, anyone who can help?. I've tried everything, and even did th re-indexing on the SQL server. Do check this site and see for yourself.

Why, are the page requesst so slow?

Thank you.
Apr 28, 2009 at 11:59 AM
Seems fine to me. Pages loaded in no time
Apr 28, 2009 at 12:37 PM
Hi bpsintl
Firstly, I thank you for taking the time to check, and I appreciate the help. Let me elaborate on what I mean.

The site loads fast, as soon as you hit the URL but :

Ater the site is loaded, go thorugh the links like "Downloads" "Biography" etc. Notice the delay between your mouse-click on the links, the "waiting for...." status on the status bar,  and the time it takes to actually get the page rendered. I'm getting at least a 4 seconds delay here in Amsterdam. The site is hosted like just 2 towns from me.

Everything remaining the same, this problem started only after upgrading to BE 1.5. Any help, on what can be done?

Thank you.
Apr 28, 2009 at 12:41 PM
I'm getting about 1.5 seconds after clicking the nav links.

I'm in the UK
Apr 28, 2009 at 12:46 PM
Do you have "Compress Web Resource.axd" checked in Setup? If so, uncheck it. That makes my dedicated server hang for about 20 to 30 seconds.

Switching it off fixed it
Apr 28, 2009 at 1:09 PM
Hi again.
Thank for the reply. No, I do not have the compression on actually, and still the same problem.  Do you think your 1.5 seconds delay is normal?. Even if so, I wonder why I get 4 seconds delay. No matter what the OS or the browser is.

I'm wondering if there is any kind of IIS tune-up needed?. I'm running this on IIS 7 .NET 3.5 SP1 , by the way. Does that make any difference?

Apr 28, 2009 at 1:12 PM
Not sure then to be honest. I'm on a Win 2003 server with IIS6 so can't comment on IIS7.

Maybe someone else has an idea?
May 8, 2009 at 9:23 PM

See this post from today.  It could be the Twitter widget that's causing the slowness.  Try temporarily removing that widget to see if it makes a difference.