An item with the same key has already been added => 100% CPU

Jul 4, 2014 at 8:42 AM
Hi,

The website is 100% CPU.

Here is the stacktrace :
Exception information: 
    Exception type: ArgumentException 
    Exception message: An item with the same key has already been added.
   at System.Collections.Generic.Dictionary`2.Insert(TKey key, TValue value, Boolean add)
   at BlogEngine.Core.AuthorProfile.get_Profiles()
   at BlogEngine.Core.AuthorProfile.GetProfile(String username)
And another stacktrace :
Exception information: 
    Exception type: ArgumentException 
    Exception message: An item with the same key has already been added.
   at System.Collections.Generic.Dictionary`2.Insert(TKey key, TValue value, Boolean add)
   at BlogEngine.Core.AuthorProfile.get_Profiles()
   at BlogEngine.Core.AuthorProfile.GetProfile(String username)
   at post.OnInit(EventArgs e) in d:\Inetpub\www\post.aspx.cs:line 111
   at System.Web.UI.Control.InitRecursive(Control namingContainer)
   at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)
Aug 7, 2014 at 6:24 AM
Hi MasterG,

which version of BlogEngine are you using ?
Aug 7, 2014 at 6:32 AM
I think this is same issue posted here (no response there too) - https://blogengine.codeplex.com/discussions/540805 . it was 2.8
Aug 7, 2014 at 10:18 AM
I'm using 2.9 and I will wait a bit before upgrading to the 3.0
Aug 7, 2014 at 10:23 AM
Did you solved the issue ?
Aug 7, 2014 at 10:24 AM
Nope, I've modified the workerprocess to restart if it consumes too many CPU.
Aug 7, 2014 at 10:28 AM
I have this issue. after upgrading to version 3.0 :(
Aug 14, 2014 at 7:49 PM
Edited Aug 14, 2014 at 8:02 PM
I'm also having this problem. Did anybody solved it yet? Without restarting the server.
Aug 15, 2014 at 2:43 AM
Check the error logs on Dashboard and do fixes accordingly, may solve the issue.
Aug 15, 2014 at 7:01 AM
Thanks for the tip.

I'm getting this alot:
Date: 24-3-2014 9:09:59
An attempt to download a remote file has been halted due to unknown content length: http://automateitapp.com/

These are just normale links in the article.

Any idea?
Sep 3, 2014 at 6:42 PM
Did you ever find a cause of the repeated error log?