This project is read-only.

BlogEngine 3.0 recaptcha or simple captcha enable

Topics: ASP.NET 2.0, Controls
Jul 29, 2014 at 6:19 AM
I have installed BlogEngine 3.0. I am trying to simple captcha / recaptcha. Is there any documentation/ support guide to enable both of these features ?

Please help!
Jul 29, 2014 at 3:17 PM
The UI looks a little different, but process still very much the same: enable recaptcha.
Aug 7, 2014 at 6:06 AM
On the extensions page in 3.0 admin, the checkboxes are disabled (RECAPTCHA is enabled) but I cannot find where to add the private and public keys?
Aug 7, 2014 at 11:40 PM
You have to click on the link "RECAPTCHA". A dialog box pops and you can scroll down to enter keys.
Aug 8, 2014 at 12:20 AM
Thx, I got the keys entered. But I don't know why all these checkboxes are disabled. We're also starting to have issues with roles and admin not being able to add hyperlinks in editor (3 browsers so far). I will update later when I know more.
Jan 19, 2015 at 11:54 AM
BlogEngine.Net 3.1 has lots of improvements.

However it seems like BlogEngine.Net 3.1 has lots of bugs too. I'm facing following problems related to enabling recaptcha: gives me the list of extensions

All tickboxes are grayed out and gives a red circle when I hover over them.
Neither I can enable/disable extension nor change settings. If I click on the recaptcha extension it gives me

I tried the old URL(one that used to work BE 2.8) with no luck.
I am running BlogEngine.Net 3.1 (using SQL Server) on Microsoft Azure.
Jan 21, 2015 at 8:31 AM
My bad! I'm sorry. recaptcha is working. Also I can enable/disable extensions. All I had to do is enable "manage extensions" for Administrator under Users - > Roles.

One hint: I had to logout and login again.
Jan 21, 2015 at 3:25 PM
I have, I have enabled recaptcha, set the public key and private key, Enabled the extension. But the recaptcha does not show when entering or submitting a comment. Simple Captcha was enabled by default, so I disabled that and recaptcha still does not show. I logged in and out a few times, still no luck. With recaptha enabled, even if you wanted to submit a comment, it errors... "There was an error in the callback"