All Admin Pages are blank

Topics: Themes
Jul 30, 2014 at 12:08 AM
I've upgraded a blog multiple versions using the SQL scripts to Blogengine version 3.0. All looks good on the front end pages all show up.

But when I login with admin it redirects me to a blank page. I can not get to any admin tabs at all. They are all blank.

Can someone help us debug this?

Windows 2012 R2 / IIS 8.5

Blogengine was upgraded from 2.0 and has a custom theme/site.master.

I wish there was an error reported, but I get a blank page. I also noticed that after admin login, blogengine tries to redirect to /blog/views/dashboard.html but gets a 404. Which is expected since the act file is at /blog/admin/views/dashboard.html . Is this a symptom of something else going wrong? I've double-checked permissions and everything else.

Any pointers would be greatly appreciated.
Jul 30, 2014 at 12:18 AM
More information....

using "/admin" results in a blank page with "/admin#/" URL.

But using "/admin/" ( note trailing slash ) results in me being redirected to the login page again. Even though I'm logged successfully since I can see that I now have post edit privileges on the home page.
Jul 30, 2014 at 12:49 AM
Further debugging with Fiddler turns up a 500 error while logging on from this URL...

/blog/api/comments?filter=IsDeleted+%3D%3D+false&order=DateCreated+descending&skip=0&take=5&type=5

Does anyone have information on how I can get a stacktrace from that 500 error?
Coordinator
Jul 30, 2014 at 3:29 PM
Do you see "administration" menu after log in with links to admin pages?
Normally, admin links should be something like /admin/#/blogs, "/admin/#/content" etc. And because it is driven by Angular.js - any JavaScript errors?
Jul 30, 2014 at 9:50 PM
I get black administration pages as well. For example http://localhost/blog/admin/#/users/profile is blank. The following is the HTML.

<html>
<head>
    <style type="text/css">

        @charset "UTF-8";[ng\:cloak],[ng-cloak],[data-ng-c…

    </style>
    <title></title>
    <link type="image/x-icon" href="/blog/pics/blogengine.ico" rel="shortcut icon"></link>
    <meta charset="utf-8"></meta>
    <meta content="IE=edge, chrome=1" http-equiv="X-UA-Compatible"></meta>
    <meta content="yes" name="apple-mobile-web-app-capable"></meta>
    <meta content="black" name="apple-mobile-web-app-status-bar-style"></meta>
    <meta content="telephone=no" name="format-detection"></meta>
    <meta content="width=device-width, initial-scale=1.0, maximum-scale=1.0, user-scalable=no" name="viewport"></meta>
    <link rel="stylesheet" href="/blog/Content/bootstrap.min.css"></link>
    <link rel="stylesheet" href="/blog/Content/toastr.css"></link>
    <link rel="stylesheet" href="/blog/Content/font-awesome.min.css"></link>
    <link rel="stylesheet" href="/blog/Content/editor.css"></link>
    <link rel="stylesheet" href="/blog/Content/app.css"></link>
    <link rel="stylesheet" href="/blog/editors/summernote/summernote.css"></link>
    <script type="text/javascript"></script>
</head>
<body>
    <script src="admin.res.axd" type="text/javascript"></script>
    <div id="container" class="app-wrapper ltr">
        <div id="ng-view" data-ng-view="" data-ng-app="blogAdmin"></div>
    </div>
    <script src="/blog/scripts/jquery-2.1.0.js"></script>
    <script src="/blog/scripts/jquery.validate.js"></script>
    <script src="/blog/scripts/jquery.form.js"></script>
    <script src="/blog/scripts/toastr.js"></script>
    <script src="/blog/Scripts/angular.min.js"></script>
    <script src="/blog/Scripts/angular-route.min.js"></script>
    <script src="/blog/Scripts/angular-animate.min.js"></script>
    <script src="/blog/Scripts/angular-sanitize.min.js"></script>
    <script src="/blog/admin/be-grid.js"></script>
    <script src="/blog/admin/app.js"></script>
    <script src="/blog/admin/controllers/dashboard.js"></script>
    <script src="/blog/admin/controllers/blogs.js"></script>
    <script src="/blog/admin/controllers/posts.js"></script>
    <script src="/blog/admin/controllers/pages.js"></script>
    <script src="/blog/admin/controllers/tags.js"></script>
    <script src="/blog/admin/controllers/categories.js"></script>
    <script src="/blog/admin/controllers/files.js"></script>
    <script src="/blog/admin/controllers/comments.js"></script>
    <script src="/blog/admin/controllers/users.js"></script>
    <script src="/blog/admin/controllers/roles.js"></script>
    <script src="/blog/admin/controllers/profile.js"></script>
    <script src="/blog/admin/controllers/settings.js"></script>
    <script src="/blog/admin/controllers/tools.js"></script>
    <script src="/blog/admin/controllers/commentfilters.js"></script>
    <script src="/blog/admin/controllers/blogroll.js"></script>
    <script src="/blog/admin/controllers/pings.js"></script>
    <script src="/blog/admin/controllers/packages.js"></script>
    <script src="/blog/admin/controllers/common.js"></script>
    <script src="/blog/admin/services.js"></script>
    <script src="/blog/scripts/bootstrap.js"></script>
    <script src="/blog/scripts/moment.js"></script>
    <script src="/blog/editors/summernote/summernote.js"></script>
</body>
</html>

Can somebody please post a solution.
Jul 30, 2014 at 9:55 PM
For me the problem only occurs when running the site as an application in order for it to appear as a subdirectory to the website.
Jul 30, 2014 at 10:20 PM
OK I seem to have found the problem after some searching. I had to wrap sections in the website with <location path="." inheritInChildApplications="false">

<location path="." inheritInChildApplications="false">
<system.web>...<system.web>
</location>

<location path="." inheritInChildApplications="false">
<system.webserver>....<system.webserver>
</location>
Jul 30, 2014 at 10:50 PM
@rtur Thanks for that tip. That helps a lot. /blog/admin/#/content works.

Now that I can get to the blog I went into the "roles" tab and give the Administrators group all permissions. And that seems to fixed the issue.

Administrator didn't have the "View Dashboard" permission. Now it does, it works. I still see the "500" status loading recent comments, but that doesn't seem to have broken anything.

I've also made a donation on the website out of gratitude. Thanks! :)