Deployment to Hosted Environment Problems (v1.5)

May 13, 2009 at 7:38 AM

Basically having this issue when deploying to a hosted site, it worked when I installed locally where the site was the root.  If anyone has any tips, much appreciated.

Server Error in '/' Application.


Configuration Error

Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

Parser Error Message: This configuration section cannot be used at this path.  This happens when the site administrator has locked access to this section using <location allowOverride="false"> from an inherited configuration file.

Source Error:

 

Line 52: 		
Line 53: <globalization requestEncoding="utf-8" responseEncoding="utf-8" culture="auto" uiCulture="auto"/>
Line 54: <httpRuntime enableVersionHeader="false" useFullyQualifiedRedirectUrl="true" maxRequestLength="16384" executionTimeout="3600" requestLengthDiskThreshold="16384"/>
Line 55: <machineKey validationKey="D9F7287EFDE8DF4CAFF79011D5308643D8F62AE10CDF30DAB640B7399BF6C57B0269D60A23FBCCC736FC2487ED695512BA95044DE4C58DC02C2BA0C4A266454C" decryptionKey="BDAAF7E00B69BA47B37EEAC328929A06A6647D4C89FED3A7D5C52B12B23680F4" validation="SHA1" decryption="AES"/>
Line 56:
May 13, 2009 at 11:41 PM

Looks like your host might have <httpRuntime> locked down in the machine.config. I'm not sure what the consequences of removing it from the BlogEngine.Net web.config file is, but it's likely the only way you'll be able to get it to work (unless you can talk your hosting provider into altering the machine.config to allow overrides).