What am I doing wrong?

Sep 9, 2014 at 12:08 AM
I am running BE 3.0, using Visual Web Developer Express I copy a custom aspx page and the .cs file into my website, I compile it and publish the page and deploy BlogEngine.NET.dll to the server. I try to load the page on the server and I get a can't find page error. It loads locally.
Sep 11, 2014 at 1:20 AM
Hi Jerry,

If it works Locally but not on the server you then got to think in terms of

"What is different?"

I bet the issue is with the .cs file being compliled into the .DLL

You might want to try to delete the BlogEngine.Net.dll from the server first.

Then FTP your Local BlogEngine.Net.dll into your server folder.


After that go to your Website Panel.

Go to Websites and Stop both Application and Website.

Let it stop for about 2-3 mins to clear out the app_pool.

Then start it back up.

It should be working.


IF that does not work try uploading the .cs directly to the server.

I find sometimes magically somehow the server just absorbes the code behind files :)


Had this issue with the default.aspx and default.cs pages.


I upload the default.cs page and later on it disappears.
Marked as answer by jerrysdean43 on 9/10/2014 at 8:36 PM
Sep 11, 2014 at 4:36 AM
Thanks Brian, worked great.
Sep 11, 2014 at 4:38 PM
Hi Jerry,

Glad that it worked for you :)

Have a great day!

Brian Davis

http://BloggersOnline.com