WebHost helping customer manage blogengine site

Topics: ASP.NET 2.0, Themes
Feb 4, 2015 at 11:31 PM
I am a webhost that has a customer with a blogengine.net site. The person that was managing the site is no longer with the customer's business and I have been asked to help them figure out how to make edits. I have no experience with this platform aside from setting it up on our servers so I have a few questions I am hoping I can get answered quickly:

NOTE: site is set up to use xml post rather than a mssql database.

1) How can I determine the version of blogengine.net they are using. I have looked through the admin as well as some files in the code and cannot locate anything that indicates a version.

2) When I am in the dashboard admin, it states there are 12 pages that have been created. When I try to view them, the landing page is blank and no pages are listed. The pages are active on the site just not showing up in the admin. How can I get them to show up in the admin area so they can be edited.

3) how can I edit the information on the contact form page (contact.aspx) without having to do it manually in [App_data/settings.xml] ?
Feb 5, 2015 at 2:15 AM
Hi Cognecy,
  1. Did you look at the footer of the admin pages? If it is taken out you have to manually put this in some where
<%=BlogSettings.Instance.Version() %>

That will tell you what the version is :)
  1. Do you have edit rights for pages and posts?
  2. Contact is a stand alone page, not editable through BE page editor.
You can edit the

Form message and the Thank you message from the admin side:


If you need to edit anything else you have to do it on the contact.aspx page.

If you need to add additional fields you have to also edit the code behind file too:


That should do it :)

If you have any additional questions please ask.

Have a great day!

Brian Davis
Feb 5, 2015 at 4:50 AM
Okay, I have got the version now ... it is [ ]

I am logged in as [Admin] but still I cannot see any pages in the admin dashboard. The Admin is set up with Administrator Role so but nothing I do will allow me to see the existing pages in the dashboard. I must be missing something but do not know what it is.

Below is what I see in the dashboard area:



Any suggestions?
Feb 5, 2015 at 6:47 PM
Hi Cognecy,

It seems like it might be an issue with Web API on server.

To confirm this get Firebug:


Go to Admin section with Firebug with Network showing.

It will show you any error message, betting getting an error from API permissions.

On another note, I would do a fresh install of BE 3.0 :)

BE 2.0 is very very out dated :)