Syntax error : js.axd

Topics: ASP.NET 2.0, Controls
Jun 12, 2009 at 8:50 AM
Edited Jun 12, 2009 at 11:08 AM

Hello everyone, we just using the Blog Engine .NET on the web site below, however while working and debugging on Visual Studio 2008, everything is fine, posting works , no errors while loading the page , it just runs.

However….

When we copy over the site to the production IIS 6 server we get this error every time it loads the website…

Webpage error details

User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; Core Computing PC 1.0; Tablet PC 2.0; InfoPath.3; SaturnLibertyDesktop 4.0.5060)
Timestamp: Fri, 12 Jun 2009 08:38:48 UTC


Message: Syntax error
Line: 2
Char: 1
Code: 0
URI: http://www.alarconyasociados.com/blog/js.axd?path=http%3a%2f%2fwww.alarconyasociados.com%2fblog%2fWebResource.axd%3fd%3dj246orv_38DeKtGbza6y6A2%26amp%3bt%3d633802465468281250


Message: Object expected
Line: 216
Char: 1
Code: 0
URI: http://www.alarconyasociados.com/blog/

It really wouldn’t be that bad if it just had the error but this is preventing users to post comments or rate posts.

Since it’s the first time we use Blog Engine .NET we really have no clue on what’s going on…

On the same server we have sites using ASP.NET 2 and they all work without problems, even upload function work.

Maybe someone more experienced on Blog Engine .NET can help us out here.

Here is the test post so you can try it.

http://www.alarconyasociados.com/blog/post/2009/06/12/Test-Debug-Post.aspx

Thanks.

 

Coordinator
Jun 12, 2009 at 10:51 AM

On the Settings tab in the Control Panel, in the Advanced Settings section, try unchecking the "Compress WebResource.axd" box and Save Settings to see if that makes a difference.

Jun 12, 2009 at 11:09 AM

It did something...

 

The new error is:

Webpage error details

User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; Core Computing PC 1.0; Tablet PC 2.0; InfoPath.3; SaturnLibertyDesktop 4.0.5060)
Timestamp: Fri, 12 Jun 2009 11:08:05 UTC


Message: 'notify' is undefined
Line: 2
Char: 1566
Code: 0
URI: http://www.alarconyasociados.com/blog/js.axd?path=%2fblog%2fblog.js&v=1.5.0.7

 

Coordinator
Jun 12, 2009 at 8:53 PM

Have you modified the blog.js file in the root of your blog?  It appears to be missing code.  For example, in the addComment() JS function, a bunch of variables are declared.  They're declared for "author", "email", ""website", "country", "content", "notify", "captcha", "replyToId", "callback", etc..

However, in your blog.js file at the link below, some of that is missing.

http://www.alarconyasociados.com/blog/blog.js

I would either replace the missing code, or replace the entire blog.js file with the blog.js file that comes with BE.

Jun 12, 2009 at 9:51 PM

We didn’t change anything on the blog.js file, however it was missing parts the file size was smaller than the one from the blog release.

The error is now gone and everything seems to be working fine…

Next time something like this happens we will put special attention to the small details.

Thanks for the help.

 

Jul 31, 2009 at 6:50 AM

I was having the same issues and I followed BenAmada's advice:

"On the Settings tab in the Control Panel, in the Advanced Settings section, try unchecking the "Compress WebResource.axd" box and Save Settings to see if that makes a difference."

The errors aer now gone. Thanks BenAmada.