Unable to Add New Entries

Topics: ASP.NET 2.0
Jul 3, 2009 at 7:26 AM

I made a bit of a mstake early in the week when upgrading some of my website. I accidently started deleting the Blog directory. I stopped the delete as soon as I realised but a lot of files had been scrapped. Luckily I'd backed up everything before hand so I proceeded to overwrite the Blog directory with my backup.

Everything seemed to go ok and the blog was once again available. However now when I tried to Add a Blog it let's me login and type the post but when I click save I get an error:

This one's down to me! Please accept my apologies for this - I'll see to it that the developer responsible for this broken link is given 20 lashes (but only after he or she has fixed this problem).

You can also try to search for the page you were looking for:

The URL is http://mydomain.com/Blog/error404.aspx?aspxerrorpath=/Blog/admin/Pages/Add_entry.aspx

I've also tried adding an entry as admin with the same result.

Jul 3, 2009 at 8:53 AM

My apologies. I overlooked a simple issue which I've now fixed.

After replacing the deleted directories the permissions had been reset and I simply added the modify rights for the ISUR to the App_Data directory to get it going.