Access to the path . . . hash.web denied

Topics: ASP.NET 2.0
Jul 15, 2009 at 6:20 PM

Hi CodePlex,

I have installed a version of BlogEngine in May 2009, and have been successful with working with the application steadily in the past 2 months until the other day when I encountered a work-stoppage error. Access and performance of BlogEngine on my Windows Vista (64-bit) came to a complete halt on Monday this week when I encountered the following error:

   

Server Error in '/BlogEngine.Web' Application.

Access to the path 'C:\Windows\Microsoft.NET\Framework\v2.0.50727\Temporary ASP.NET Files\blogengine.web\e2232096\ff99aa4\hash\hash.web' is denied.

 

I have IIS 7 running, and shortly after I encountered this error on my default.aspx page, I did a system reboot thinking that it would "correct" the problem. In the process, I received a Windows Update prompt, and installed the recent Windows Updates for my machine, and also downloaded the most recent version of IE 8.

The error reproduced again following the reboot, and is replicated on Firefox 3 as well.

Upon investigation, I tried to make further changes required for setting up BlogEngine's performance requirements -- things I missed when I initially started my project. For instance, I established Read / Write permissions on the App_Data directory for BlogEngine, and added aspnet as a user under Security Permissions. However, additional user permissions could not be added in IIS 7 -- adding new user permissions under the IIS manager were greyed out, preventing me from adding my machine's iusr profile.

I tried to reproduce the project on another machine, and found that I was getting other errors on that machine running Windows Vista (32-bit), and on a machine running Windows XP.

What am I missing here?

Thanks in advance.

Eric / Seattle, Washington

Coordinator
Jul 16, 2009 at 5:42 AM

I would take a look at what others with this same error have done.  A quick glance at some of the search results shows it may be related to the Indexing Service.

Google Search
http://www.google.com/search?q=hash.web

Jul 24, 2009 at 6:11 PM
BenAmada wrote:

I would take a look at what others with this same error have done.  A quick glance at some of the search results shows it may be related to the Indexing Service.

Google Search
http://www.google.com/search?q=hash.web

 

Hi Ben,

Yes, I did search. I looked to see if anyone else has had issues with BlogEngine and this error. To no avail. There are resources online that address the hash.web issue, and several folks suggest to stop the (Windows Search in the IIS manager) indexing service to see if that clears the error. It does not, and the indexing service does not seem to be related to this instance of the hash.web error. Starting and stopping the indexing service raises the same error.

Thanks for your feedback.

Sep 18, 2009 at 4:17 PM

Hi, you may have .NET 1.1 apps running and your sharing the application pool with them. Read the second section in our post below;

http://blog.beginning-internet-marketing.com/post/BlogEngine-dot-net-installation.aspx