Switch From http to https

Topics: Business Logic Layer
Aug 10, 2016 at 10:33 PM
Edited Aug 10, 2016 at 10:42 PM
I recently switched my site to https but Utils.AbsoluteWebRoot does not pick up the change. Is there something I am missing to force the change? I also noticed that the sitemap.axd is still showing http in the urls instead of https
Aug 22, 2016 at 9:48 PM
Can anyone help with this question please?
Dec 6, 2016 at 12:00 AM
Still looking for a solution to this issue. Using BlogEngine.net 2.8
Dec 7, 2016 at 5:07 PM
I switched to https. I use Blogengine 3.3 on IIS.
Used letsencrypt to get certs. No problems.
Dec 19, 2016 at 9:48 PM
Use the method LEOF used. Use IIS as the redirector and set up some rules in your web.config. Use your certs and import them into the SSL settings. IIS is very good at redirecting and SSL termination.