This project is read-only.

Blank default page after deployment

Aug 18, 2016 at 4:45 PM
Edited Aug 18, 2016 at 4:46 PM
I have BlogEngine.NET 3.3 working fine using VS 2013 and a localdb. I tried deploying that to another computer using the 'FileSystem' method, and then on the destination converting a virtual directory under IIS to an application, editing web.config...

Initially I tried to get the localdb to work with IIS on the destination system after trying to jump through many documented hoops... I ended up switching to SQLEXPRESS, attaching the db there, had some access errors initially, but resolved those after the IIS APPPOOL\.NET v4.5 login and role member settings were in place... so now, I'm no longer getting sql error messages in the browser with localhost/blog on the destination system... however, now there is nothing but blank pages.. even with the full path http://localhost/blog/default.aspx, a blank page... The bin folder seems to have all the expected dll's, so I'm not sure where to go from here, haven't found an appropriate solution so far... ideas? Thank you!
Aug 18, 2016 at 7:57 PM
Ok, so it seems that a couple of my Theme folders did not copy over... all is well now, but I'll have to see if I can get that to copy over the next time I attempt to publish...