Email help please!

Oct 27, 2009 at 2:52 PM

I have recently installed BlogEngine v1.4.5 and cannot get email to work ot save my life.  I read an article that said I needed to change the "trust level" setting in my web config from high to full - but i don't even see that seting in my web.config.  I have tried every combination of values I can think of, using multiple accounts - but no matter what I do I just get a "cannot connect" error.  I am to the point that I am willing to pay someone, anyone who can get this thing working.  Specifically I would like to use a gmail account.  I've tried:

SMTP Server: smtp.gmail.com / SSL: true / Port: 587 (alos tried 25 and 465)  nothing seems to work...

 

Coordinator
Oct 27, 2009 at 11:40 PM

You shouldn't need full trust if you stick with port 25.

smtp.gmail.com is right.  Try port 25, and check "Enable SSL", and enter your username and password.  The email address should of course be your Gmail email address.

Coordinator
Oct 27, 2009 at 11:55 PM

Btw, is your blog on a web server at a web host, or just on your local computer?  If it's on your local computer and you have home service with your ISP, oftentimes ISPs block outgoing port 25 traffic.  In that case, you would want to use one of the other ports (465, 587) -- and full trust would be required then.  For some reason, specifying a port other than 25 is not allowed in a medium trust environment.

Oftentimes, if port 25 is blocked by your ISP, when you try to send an email through that port, it takes 30 seconds before the attempt fails.  So if you're seeing a long delay before the failure, it could be because of a blocked port.

Oct 28, 2009 at 7:19 AM

Hi,
 You can try hotmail SMTP server by creating hotmail account.

SMTP server: smtp.live.com  port 25

Authontication required: yes

Enable SSL: yes

-Satalaj