Linking to the blog fails with error message

Nov 5, 2009 at 7:00 PM
Edited Nov 5, 2009 at 7:05 PM

Hi,

When I create links to my blog posts from my main website I regularly receive one of two error messages (see below):

If I try the link a second time it works from the same browser session it works. What could be going wrong? Here are example links that fail:

http://pavilioncompounding.com/Blog/BlogEngine/post/Pediatric-Options-for-Compounding.aspx

http://pavilioncompounding.com/Blog/BlogEngine/

 

ERROR MESSAGES:

Ooops! I can't find the page you're looking for

This one's down to me! Please accept my apologies for this - I'll see to it that the developer responsible for this broken link is given 20 lashes (but only after he or she has fixed this problem).

You can also try to search for the page you were looking for:

 

Ooops! I can't find the page you're looking for

You were incorrectly referred to this page by: localhost

I suggest you try one of the links below:

 

 

 

Nov 5, 2009 at 7:17 PM

Found this in another thread, going to try it:

 

"Yes, I did turn customErrors off and then saw some gibberish on every first load.  It looked like a memory dump. 

Anyhow, the evil was that I didnt set the .NET Trust Level to High but instead it was set to Medium which I believe caused the failed first loads.  As soon as I set it to High, it worked fine."

Nov 5, 2009 at 7:29 PM

The Website is on a shared host and the webhosting company will not change the Trust Level for the application. Am I out of luck?

 

Nov 5, 2009 at 9:19 PM

Hi acidjazz,

FWIW, both of your links loaded fine for me (using IE 8) on the first try. It seems odd that it loads the Archive page as a default page, but it loads w/out error.

BTW, if it were me, and I was providing a link to go directly to the "Pediatric Options for Compounding" post, I'd use the "permalink" link which is at the bottom of the post rather than the "SEO Friendly" link that you get at the top of the post.  If you're putting the link into a page, you can make the link read "Pediatric Options for Compounding" but set the "href" attribute to the longer, uglier, but more reliable permalink.

 -GayLyn

 

Nov 6, 2009 at 4:54 AM

Thanks GayLyn on the Permalink idea. The archive displays because I changed the custom 404 in web.config to load the archive.aspx instead of the error page since the page always fails on the first load. This way the user is greeted with the archive page instead of the oops page.  Not optimal but, an improvement.