Akismet causing issue when enabling

Dec 6, 2009 at 2:04 AM

I tried to enable Akismet but when I clicked Enable, it threw an exception:

Changes will not be applied: Access to the path '<Path removed for obvious reasons>\web.config' is denied.

What is it expecting to do to the web.config file?

Dec 6, 2009 at 4:20 AM

OK, I looked at the code.  I see you try to 'touch' the web.config file to reset the site. 

I think the message shown when this fails, could be tweaked. 

Coordinator
Dec 6, 2009 at 4:41 AM

To enable/disable extension, BE needs to restart web application. It is doing it by updating time stamp on web.config, which forces IIS to reload app. Recycling pool programmatically does not work in medium trust on hosting servers.

 

Dec 6, 2009 at 4:44 AM

Yep, I understand.  I'm just thinking the message could be tweaked to better state what went down.

Feb 11, 2010 at 12:20 AM
Edited Feb 11, 2010 at 12:21 AM

add these keys to your web.config:

 

<appSettings>

<add key="ProxyHost" value="http://wc-v01.inet.mesa1.gdg" />

<add key="ProxyPort" value="3128" />

</appSettings>

 

Tommy Ong
Web Design & Development