Permision Denied / Missing file

Dec 10, 2009 at 7:33 PM

Trying a new install and I get the follwoing error when trying to access the blog.

Access to the path

c:\inetpub\blog\App_Data\datastore\extensions\AkismetFilter.xml' is denied.

I have added the appropriate write permissions to Network Service and cleared the the "Read Only' flag. When checking that folder, it seems that that file does not even exist.

Coordinator
Dec 10, 2009 at 7:41 PM

Check this out.

 

Dec 10, 2009 at 7:50 PM
Edited Dec 10, 2009 at 8:18 PM

I checked that out, but it did not help, The Process Model Identity was already set to NetworkService. I also downloaded the "check" file, dropped that folder inside the blog directory but I still get the same error when trying to access /blog/check.

 

EDIT - It seems maybe it did not compile properly or something. I download the latest source code (Change Set 30638) re-compiled it I know longer get that error. 

Thanks for your help rtur

Dec 15, 2010 at 12:06 PM

I am getting the same error as the OP but if I refresh the page then everything works!

Any ideas?

Coordinator
Dec 15, 2010 at 7:06 PM

It could be that whenever the blog starts, this error occurs.  But then on subsequent page loads, an attempt to access the file no longer is done .... so you don't see the error message again -- until the blog restarts again and tries to access this file.

You could manually restart your blog, and then pull up your blog in your browser to see if this error occurs again (i.e. if it occurs everytime after the blog has restarted).  You can manually restart your blog by making any change to the web.config file in the root folder (i.e. add a space in the file and save).

Jan 29, 2011 at 5:16 AM

I'm having this same problem. I change something in settings, or edit a post, or make a new post.

I get the error message: Could not save post: Access to the path 'C:\Inetpub\xxxxx\App_Data\posts\c3b491e5-59ac-4f6a-81e5-27e971b903ed.xml' is denied.

But then, when I go back and check the post or setting, it has been changed.

So, it looks like the change is being saved, but the error is displayed. I have tried restarting the site, no luck. I'm using the XML version. Please help!

Coordinator
Jan 29, 2011 at 10:12 AM

It's possible the change is not being saved to disk ... and is only there in memory.

If you restart your blog, you can see if the changes are still there.  You can restart your blog by making any change to the web.config file (add a space, etc).  The blog will automatically restart by itself too once in a while ... if it's inactive for a while, or the application pool recycles, etc.

You can also check that XML file in the location indicated in the error message to see if the changes you made to the post are actually there.

Generally that error message (Access to the path ... is denied) means Write permissions are not enabled for the ASP.NET account.  BE needs Write permissions in order to save data to the App_Data folder.

Is this an existing blog and the error just start happening?  Or is it a new blog and you've been seeing this error since starting it?  If it's a new blog, and you're seeing this error message, then probably Write permissions are not setup for the App_Data folder.

Feb 7, 2011 at 11:38 PM

I got everything running. This is what I found:

1. IIS was not configured for ASP.NET 4

2. Privileges not properly set.

No problems with code to solve the problem.

Thanks!

Stephanie