Can't login to new install

Dec 16, 2009 at 3:14 AM

I'm having issues with the widgets not showing up on my new install. See here:

http://blogengine.codeplex.com/Thread/View.aspx?ThreadId=78288

Not sure if it's related or not, but I can't login to my new intall either.

I click 'Log In' enter admin/admin, and then it redirects back to default.aspx and still says 'log in'.

Anything I should specifically check for that might be the culprit?

Using 1.5.0.7 with the XML data storage.

Dec 17, 2009 at 1:07 AM

Well, I went ahead and tried installing this on localhost and have the exact same problem. Logging in just redirects me back to the main home page. I'm not logged in. I don't get an error.

Any theories?

 

Dec 17, 2009 at 5:38 AM

aha! I stumbled upon this post:

http://blogengine.codeplex.com/Thread/View.aspx?ThreadId=59132

ktimby was having issues with blogengine.net being a subfolder of a root application where that app's web.config was interfering in some way with blogengine.net.

I'm in a similar situation. blogengine is installed in /blog which is a app folder inside of a .net 1.1 root application.

After some trial and error, the culprit is that I've set up forms authentication in the root application:

<authentication mode="Forms">

So, that leaves the question: What (if anything?) can I do to not have this web.config interfere with blogengine.net?

Dec 17, 2009 at 6:28 AM

It looks like a common solution is to use the <clear/> tag in the child app's config file.

 

I tried adding it as such into blogengine's config file:

 

<authentication mode="Forms">

    <clear/>

    <forms...

 

Alas, that produces a syntax error.

Dec 18, 2009 at 2:31 AM

Me again.

In summary: The situation is that if you install BE.net into an app folder that is a child of an app folder, you may end up getting conflicting web.config files as the child BE.net application inherits from the parent.

The solution I found was to make sure in the root application you add a location element around the settings you don't want BE.net to inherit. In this case, I didn't want BE.net to inherit my authentication as it was (for whatever reason) keeping me from logging in.

Example:

<location path="." inheritInChildApplications="false">
<system.web>
    <authentication mode="Forms">
            <forms...></forms>
    </authentication>
</system.web>
</location>