Initial setup done - where do we make a post?

Dec 29, 2009 at 5:46 PM
Edited Dec 29, 2009 at 7:46 PM

We just installed BlogEngine.NET (via Network Solutions), removed all the v1.1 files, downloaded & uploaded the  1.5 files and can can view the site: ( http://www.commercialsilk.com/toolkit3/default.aspx ).  Now, I click the Log in link enter admin/admin and I don't see any difference.  I don't see anywhere to manage anything or make a new post.  I will post the root and toolkit3 web.conf files below.   Anyone see the conflict with my root web.config file?

----------------------------------------------------------
root web.config
----------------------------------------------------------

 

<?xml version="1.0"?>
<configuration>
<configSections>
<section name="rewriter"
requirePermission="false"
type="Intelligencia.UrlRewriter.Configuration.RewriterConfigurationSectionHandler, Intelligencia.UrlRewriter" />
</configSections>


<appSettings>
<!-- START EMAIL SETTINGS -->
<add key="EMAIL-FROM" value="error@domain.com"/>
<add key="EMAIL-FROM-DNS" value="noreply@domain.com"/>
<add key="EMAIL-SMTP" value="localhost"/>
<add key="EMAIL-SAVE-EMAILS" value="0"/>
<add key="EMAIL-LOG-FILE" value="domain_email_log.txt"/>
<add key="EMAIL-ADMIN" value="lee@domain.com"/>
<add key="MACKey" value="6cd3f73a-870b-415b-9d74-058a74781dde" />
<!-- END EMAIL SETTINGS -->
</appSettings>
<connectionStrings>
<clear/><!-- this removes the inherited connectionstring -->
<add name="domainDB" connectionString="server=sqlseverdbabc123;uid=domain;pwd=xxxxx;database=domain"/>
</connectionStrings>

<system.web>
<compilation debug="false" strict="false" explicit="true" batch="false" />
<pages>
<namespaces>
<clear/>
<add namespace="System"/>
<add namespace="System.Collections"/>
<add namespace="System.Collections.Specialized"/>
<add namespace="System.Configuration"/>
<add namespace="System.Text"/>
<add namespace="System.Text.RegularExpressions"/>
<add namespace="System.Web"/>
<add namespace="System.Web.Caching"/>
<add namespace="System.Web.SessionState"/>
<add namespace="System.Web.Security"/>
<add namespace="System.Web.Profile"/>
<add namespace="System.Web.UI"/>
<add namespace="System.Web.UI.WebControls"/>
<add namespace="System.Web.UI.WebControls.WebParts"/>
<add namespace="System.Web.UI.HtmlControls"/>
</namespaces>
</pages>


<customErrors mode="On" defaultRedirect="404error.htm" />


<globalization requestEncoding="utf-8" responseEncoding="utf-8"/>



</system.web>

<system.webServer>
<modules runAllManagedModulesForAllRequests="true">
<add name="UrlRewriter" type="Intelligencia.UrlRewriter.RewriterHttpModule" />
</modules>

<validation validateIntegratedModeConfiguration="false" />
</system.webServer>

<rewriter>
<rewrite url="~/.*_p_(\d+).aspx(\?bc=(.+))?" to="~/product.aspx?id=$1&amp;bc=$3"/>
<rewrite url="~/*_s_(.+).aspx" to="~/product-listing.aspx?id=$1&amp;cd=s"/>
<rewrite url="~/*_c_(.+).aspx" to="~/product-listing.aspx?id=$1&amp;cd=c"/>
<rewrite url="~/*_b_(.+).aspx" to="~/product-listing.aspx?id=$1&amp;cd=b"/>
<rewrite url="~/*_n_(.+).aspx" to="~/product-listing.aspx?id=$1&amp;cd=n"/>
<rewrite url="~/artificial-plant-case-studies_(.*)_(.*).aspx" to="~/case-study-listing.aspx?id=$2"/>
<rewrite url="~/artificial-plant-case-study_(.*)_(.*).aspx" to="~/case-study.aspx?id=$2"/>
<rewrite url="~/cad-specs_([a-zA-Z0-9]{1,100}).aspx" to="~/request-downloads.aspx?cd=$1"/>


</rewriter>


<system.net>
<mailSettings>
<smtp>
<network host="localhost" port="25" userName="" password="" defaultCredentials="true"/>
</smtp>
</mailSettings>
</system.net>

<location path="." inheritInChildApplications="false">
<system.web>
<authentication mode="Windows"/>
<httpModules>
<add name="SampleSqlInjectionScreeningModuleVB" type="Sample.SampleSqlInjectionScreeningModuleVB"/>
<add name="UrlRewriter" type="Intelligencia.UrlRewriter.RewriterHttpModule, Intelligencia.UrlRewriter" />
</httpModules>
</system.web>
</location>
</configuration>

 

----------------------------------------------------------

----------------------------------------------------------
  toolkit3 web.config
----------------------------------------------------------

 

<?xml version="1.0"?>
<configuration>
<configSections>
<sectionGroup name="BlogEngine">
<section name="blogProvider" requirePermission="false" type="BlogEngine.Core.Providers.BlogProviderSection, BlogEngine.Core" allowDefinition="MachineToApplication" restartOnExternalChanges="true"/>
</sectionGroup>
</configSections>
<BlogEngine>
<blogProvider defaultProvider="XmlBlogProvider">
<providers>
<add name="XmlBlogProvider" type="BlogEngine.Core.Providers.XmlBlogProvider, BlogEngine.Core"/>
<add name="DbBlogProvider" type="BlogEngine.Core.Providers.DbBlogProvider, BlogEngine.Core" connectionStringName="BlogEngine"/>
</providers>
</blogProvider>
</BlogEngine>
<!-- configSource is not implemented in Mono.
<connectionStrings configSource="sql.config" />
-->
<connectionStrings>
<clear/>
<add name="LocalSqlServer" connectionString="dummy"/>
<!-- Mono complains if LocalSqlServer isn't specified -->
<add name="BlogEngine" connectionString="Data Source=MySQLServer;User ID=user;Password=password;persist security info=False;initial catalog=BlogEngine;" providerName="System.Data.SqlClient"/>
</connectionStrings>

<appSettings>
<add key="BlogEngine.FileExtension" value=".aspx"/>
<!-- You can e.g. use "~/blog/" if BlogEngine.NET is not located in the root of the application -->
<add key="BlogEngine.VirtualPath" value="~/"/>
<!-- The regex used to identify mobile devices so a different theme can be shown -->
<add key="BlogEngine.MobileDevices" value="(nokia|sonyericsson|blackberry|samsung|sec\-|windows ce|motorola|mot\-|up.b|midp\-)"/>
<!-- The name of the role with administrator permissions -->
<add key="BlogEngine.AdminRole" value="Administrators"/>
<!--This value is to provide an alterantive location for storing data.-->
<add key="StorageLocation" value="~/App_Data/"/>
<!--A comma separated list of script names to hard minify. It's case-sensitive. -->
<add key="BlogEngine.HardMinify" value="blog.js,widget.js,WebResource.axd"/>
</appSettings>

<system.web>
<compilation debug="false">
<assemblies>
<add assembly="System.Management, Version=2.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A"/>
<add assembly="System.Configuration, Version=2.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A"/>
<add assembly="System.Data, Version=2.0.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089"/>
<add assembly="System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089"/>
<add assembly="System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A"/>
<add assembly="System.Web, Version=2.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A"/>
<add assembly="System.Xml, Version=2.0.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089"/>
</assemblies>
</compilation>

<globalization requestEncoding="utf-8" responseEncoding="utf-8" culture="auto" uiCulture="auto"/>
<httpRuntime enableVersionHeader="false" useFullyQualifiedRedirectUrl="true" maxRequestLength="16384" executionTimeout="3600" requestLengthDiskThreshold="16384"/>
<machineKey validationKey="D9F7287EFDE8DF4CAFF79011D5308643D8F62AE10CDF30DAB640B7399BF6C57B0269D60A23FBCCC736FC2487ED695512BA95044DE4C58DC02C2BA0C4A266454C" decryptionKey="BDAAF7E00B69BA47B37EEAC328929A06A6647D4C89FED3A7D5C52B12B23680F4" validation="SHA1" decryption="AES"/>

<authentication mode="Forms">
<forms timeout="129600" name=".AUXBLOGENGINE" protection="All" slidingExpiration="true" loginUrl="~/login.aspx" cookieless="UseCookies"/>
</authentication>

<pages enableSessionState="false" enableViewStateMac="true" enableEventValidation="true">
<controls>
<add namespace="Controls" tagPrefix="blog"/>
</controls>
</pages>

<customErrors mode="RemoteOnly" defaultRedirect="~/error404.aspx">
<error statusCode="404" redirect="~/error404.aspx"/>
</customErrors>

<membership defaultProvider="XmlMembershipProvider">
<providers>
<clear/>
<add name="XmlMembershipProvider" type="BlogEngine.Core.Providers.XmlMembershipProvider, BlogEngine.Core" description="XML membership provider" passwordFormat="Hashed"/>
<add name="SqlMembershipProvider" type="System.Web.Security.SqlMembershipProvider" connectionStringName="BlogEngine" applicationName="BlogEngine"/>
<add name="DbMembershipProvider" type="BlogEngine.Core.Providers.DbMembershipProvider, BlogEngine.Core" passwordFormat="Hashed" connectionStringName="BlogEngine"/>
</providers>
</membership>

<roleManager defaultProvider="XmlRoleProvider" enabled="true" cacheRolesInCookie="true" cookieName=".BLOGENGINEROLES">
<providers>
<clear/>
<add name="XmlRoleProvider" type="BlogEngine.Core.Providers.XmlRoleProvider, BlogEngine.Core" description="XML role provider"/>
<add name="SqlRoleProvider" type="System.Web.Security.SqlRoleProvider" connectionStringName="BlogEngine" applicationName="BlogEngine"/>
<add name="DbRoleProvider" type="BlogEngine.Core.Providers.DbRoleProvider, BlogEngine.Core" connectionStringName="BlogEngine"/>
</providers>
</roleManager>

<siteMap defaultProvider="PageSiteMap" enabled="true">
<providers>
<add name="PageSiteMap" description="The site map provider that reads in the .sitemap XML files." type="BlogEngine.Core.Web.Controls.PageSiteMap, BlogEngine.Core"/>
<add name="SecuritySiteMap" description="Used for authenticated users." type="System.Web.XmlSiteMapProvider, System.Web, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" securityTrimmingEnabled="true" siteMapFile="Web.sitemap"/>
</providers>
</siteMap>

<httpModules>
<clear />
<add name="WwwSubDomainModule" type="BlogEngine.Core.Web.HttpModules.WwwSubDomainModule, BlogEngine.Core"/>
<add name="UrlRewrite" type="BlogEngine.Core.Web.HttpModules.UrlRewrite, BlogEngine.Core"/>
<add name="CompressionModule" type="BlogEngine.Core.Web.HttpModules.CompressionModule, BlogEngine.Core"/>
<add name="ReferrerModule" type="BlogEngine.Core.Web.HttpModules.ReferrerModule, BlogEngine.Core"/>
<!--Remove the default ASP.NET modules we don't need-->
<!-- <remove name="PassportAuthentication"/>
<remove name="Profile"/>
<remove name="AnonymousIdentification"/>-->
</httpModules>

<httpHandlers>
<add verb="*" path="file.axd" type="BlogEngine.Core.Web.HttpHandlers.FileHandler, BlogEngine.Core" validate="false"/>
<add verb="*" path="image.axd" type="BlogEngine.Core.Web.HttpHandlers.ImageHandler, BlogEngine.Core" validate="false"/>
<add verb="*" path="syndication.axd" type="BlogEngine.Core.Web.HttpHandlers.SyndicationHandler, BlogEngine.Core" validate="false"/>
<add verb="*" path="sitemap.axd" type="BlogEngine.Core.Web.HttpHandlers.SiteMap, BlogEngine.Core" validate="false"/>
<add verb="*" path="trackback.axd" type="BlogEngine.Core.Web.HttpHandlers.TrackbackHandler, BlogEngine.Core" validate="false"/>
<add verb="*" path="pingback.axd" type="BlogEngine.Core.Web.HttpHandlers.PingbackHandler, BlogEngine.Core" validate="false"/>
<add verb="*" path="opensearch.axd" type="BlogEngine.Core.Web.HttpHandlers.OpenSearchHandler, BlogEngine.Core" validate="false"/>
<add verb="*" path="metaweblog.axd" type="BlogEngine.Core.API.MetaWeblog.MetaWeblogHandler, BlogEngine.Core" validate="false"/>
<add verb="*" path="rsd.axd" type="BlogEngine.Core.Web.HttpHandlers.RsdHandler, BlogEngine.Core" validate="false"/>
<add verb="*" path="css.axd" type="BlogEngine.Core.Web.HttpHandlers.CssHandler, BlogEngine.Core" validate="false"/>
<add verb="*" path="js.axd" type="BlogEngine.Core.Web.HttpHandlers.JavaScriptHandler, BlogEngine.Core" validate="false"/>
<add verb="*" path="rating.axd" type="BlogEngine.Core.Web.HttpHandlers.RatingHandler, BlogEngine.Core" validate="false"/>
<add verb="*" path="opml.axd" type="BlogEngine.Core.Web.HttpHandlers.OpmlHandler, BlogEngine.Core" validate="false"/>
<add verb="*" path="blogml.axd" type="BlogEngine.Core.Web.HttpHandlers.BlogMLExportHandler, BlogEngine.Core" validate="false"/>
<add verb="*" path="sioc.axd" type="BlogEngine.Core.Web.HttpHandlers.Sioc, BlogEngine.Core" validate="false"/>
<add verb="*" path="apml.axd" type="BlogEngine.Core.Web.HttpHandlers.Apml, BlogEngine.Core" validate="false"/>
<add verb="*" path="foaf*.axd" type="BlogEngine.Core.Web.HttpHandlers.Foaf, BlogEngine.Core" validate="false"/>
</httpHandlers>
</system.web>

<system.webServer>
<validation validateIntegratedModeConfiguration="false" />

<!-- Enable the staticContent section below to add Expires headers to images for better performance.
Some hosting providers does not allow the staticContent section to be set. -->
<!--
<staticContent>
<clientCache httpExpires="Sun, 29 Mar 2020 00:00:00 GMT" cacheControlMode="UseExpires" />
</staticContent>
-->


<modules>
<add name="WwwSubDomainModule" type="BlogEngine.Core.Web.HttpModules.WwwSubDomainModule, BlogEngine.Core" />
<add name="UrlRewrite" type="BlogEngine.Core.Web.HttpModules.UrlRewrite, BlogEngine.Core" />
<add name="CompressionModule" type="BlogEngine.Core.Web.HttpModules.CompressionModule, BlogEngine.Core" />
<add name="ReferrerModule" type="BlogEngine.Core.Web.HttpModules.ReferrerModule, BlogEngine.Core" />
</modules>

<handlers accessPolicy="Read, Write, Script, Execute">
<add name="FileHandler" verb="*" path="file.axd" type="BlogEngine.Core.Web.HttpHandlers.FileHandler, BlogEngine.Core" resourceType="Unspecified" requireAccess="Script" preCondition="integratedMode" />
<add name="ImageHandler" verb="*" path="image.axd" type="BlogEngine.Core.Web.HttpHandlers.ImageHandler, BlogEngine.Core" resourceType="Unspecified" requireAccess="Script" preCondition="integratedMode" />
<add name="Syndication" verb="*" path="syndication.axd" type="BlogEngine.Core.Web.HttpHandlers.SyndicationHandler, BlogEngine.Core" resourceType="Unspecified" requireAccess="Script" preCondition="integratedMode" />
<add name="Sitemap" verb="*" path="sitemap.axd" type="BlogEngine.Core.Web.HttpHandlers.SiteMap, BlogEngine.Core" resourceType="Unspecified" requireAccess="Script" preCondition="integratedMode" />
<add name="Trackback" verb="*" path="trackback.axd" type="BlogEngine.Core.Web.HttpHandlers.TrackbackHandler, BlogEngine.Core" resourceType="Unspecified" requireAccess="Script" preCondition="integratedMode" />
<add name="Pingback" verb="*" path="pingback.axd" type="BlogEngine.Core.Web.HttpHandlers.PingbackHandler, BlogEngine.Core" resourceType="Unspecified" requireAccess="Script" preCondition="integratedMode" />
<add name="OpenSearch" verb="*" path="opensearch.axd" type="BlogEngine.Core.Web.HttpHandlers.OpenSearchHandler, BlogEngine.Core" resourceType="Unspecified" requireAccess="Script" preCondition="integratedMode" />
<add name="MetaWeblog" verb="*" path="metaweblog.axd" type="BlogEngine.Core.API.MetaWeblog.MetaWeblogHandler, BlogEngine.Core" resourceType="Unspecified" requireAccess="Script" preCondition="integratedMode" />
<add name="RSD" verb="*" path="rsd.axd" type="BlogEngine.Core.Web.HttpHandlers.RsdHandler, BlogEngine.Core" resourceType="Unspecified" requireAccess="Script" preCondition="integratedMode" />
<add name="CssHandler" verb="*" path="css.axd" type="BlogEngine.Core.Web.HttpHandlers.CssHandler, BlogEngine.Core" resourceType="Unspecified" requireAccess="Script" preCondition="integratedMode" />
<add name="Javascript" path="js.axd" verb="*" type="BlogEngine.Core.Web.HttpHandlers.JavaScriptHandler, BlogEngine.Core" resourceType="Unspecified" requireAccess="Script" preCondition="integratedMode" />
<add name="Rating" verb="*" path="rating.axd" type="BlogEngine.Core.Web.HttpHandlers.RatingHandler, BlogEngine.Core" resourceType="Unspecified" requireAccess="Script" preCondition="integratedMode" />
<add name="Opml" verb="*" path="opml.axd" type="BlogEngine.Core.Web.HttpHandlers.OpmlHandler, BlogEngine.Core" resourceType="Unspecified" requireAccess="Script" preCondition="integratedMode" />
<add name="BlogML" verb="*" path="blogml.axd" type="BlogEngine.Core.Web.HttpHandlers.BlogMLExportHandler, BlogEngine.Core" resourceType="Unspecified" requireAccess="Script" preCondition="integratedMode" />
<add name="SIOC" verb="*" path="sioc.axd" type="BlogEngine.Core.Web.HttpHandlers.Sioc, BlogEngine.Core" resourceType="Unspecified" requireAccess="Script" preCondition="integratedMode" />
<add name="Apml" verb="*" path="apml.axd" type="BlogEngine.Core.Web.HttpHandlers.Apml, BlogEngine.Core" resourceType="Unspecified" requireAccess="Script" preCondition="integratedMode" />
<add name="Foaf" verb="*" path="foaf*.axd" type="BlogEngine.Core.Web.HttpHandlers.Foaf, BlogEngine.Core" resourceType="Unspecified" requireAccess="Script" preCondition="integratedMode" />
</handlers>

<!-- Enable the httpProtocol section below to manipulate some HTTP headers.
Some hosting providers does not allow the httpProtocol section to be set. -->
<!--
<httpProtocol>
<customHeaders>
<remove name="X-Powered-By" />
<add name="Etag" value=" " />
</customHeaders>
</httpProtocol>
-->
</system.webServer>

</configuration>

 

 

Anyone seen this before? 

UPDATE: I found the following url that sounds exactly like my issue but I added the remove tag in the subfolder web.config file and it didn't work.  Link

 

Thanks.

Coordinator
Dec 30, 2009 at 2:17 AM

I tried logging in.  The main forms authentication cookie is being correctly set, however the ROLES cookie is not being passed from the server to the client.

I see you have the RoleProvider setup in your web.config file.  It looks setup correctly.  I'm guessing your site may be inheriting some settings from the parent application.  If you have access to the parent application, I would wrap the <system.web> section into the same <location> tag you have in your BE web.config file.

<location path="." inheritInChildApplications="false">
               <system.web>
                                ................ existing content ..............
               </system.web>
</location>

Again, this would go into the PARENT application's web.config file -- not your web.config file.  This should stop settings from propagating down to your application.  I'm not entirely sure if this will solve the problem, but is probably worth the try.

Dec 30, 2009 at 8:33 PM

I am not sure I follow what you mean by 'PARENT application's web.config'.   Would that be something I have to have Network Solutions change?   Other then the BlogEngine.NET folder/files I only have one web.config file and that's in the root folder.

 

So I need to put all my root web.config info current in the <location> </location> tags?

Dec 30, 2009 at 8:55 PM

Ok,  Got it working.

In my root web.config I changed this:

 

 <modules runAllManagedModulesForAllRequests="true">
      <add name="UrlRewriter" type="Intelligencia.UrlRewriter.RewriterHttpModule" />
    </modules>

-----------------------------------------

 

to this:

 

    <modules>
      <add name="UrlRewriter" type="Intelligencia.UrlRewriter.RewriterHttpModule" />
    </modules>


 

-----------------------------------------
In my /toolkit3 main web.config I changed the httpModules to be the following:

 

<httpModules>
			
			<add name="WwwSubDomainModule" type="BlogEngine.Core.Web.HttpModules.WwwSubDomainModule, BlogEngine.Core"/>
			<add name="UrlRewrite" type="BlogEngine.Core.Web.HttpModules.UrlRewrite, BlogEngine.Core"/>
			<add name="CompressionModule" type="BlogEngine.Core.Web.HttpModules.CompressionModule, BlogEngine.Core"/>
			<add name="ReferrerModule" type="BlogEngine.Core.Web.HttpModules.ReferrerModule, BlogEngine.Core"/>
			<!--Remove the default ASP.NET modules we don't need-->
			<!-- <remove name="PassportAuthentication"/> 
			<remove name="Profile"/>
			<remove name="AnonymousIdentification"/>-->
	
		</httpModules>

Got in and changed users so will see how it goes.  Thanks for the help.

 

Mar 3, 2010 at 11:55 PM

THANK YOU!  I was beating my brains out over this, there is no note of this in the documentation (might be an idea to add it).

After I installed this wonderful system, one could not view posts unless they were logged in, which isn't what I intended.

To resolve I wrapped the <system.web> tags with the forementioned:

<location path="." inheritInChildApplications="false">

</location>

 

tags.  THANK YOU!!!! It now works without loggin in, in otherwords, my posts are publicly available.

 

Mar 3, 2010 at 11:57 PM

I should clarify, I placed this blog application beneath a root website as a seperate web application.  I made the modifications to the root web.config, not the blog web.config.