Help Extension

Topics: ASP.NET 2.0, Controls
Jan 15, 2010 at 2:19 PM

Hello,
First excuse me for the inconvenience but I would like help with a problem I have.
I installed BlogEngine into my web space and tell the truth I did not encounter any major problems.
The only thing I can not operate, are the Extension.
Let's see if I can explain what happens to me.
If you already left those basic things happen to me most strange. O existing ones stop working, or some work and others do not, or even disappear from the Control Panel dell'Extension Manager. I just installed for example eliminate AkismetFilter.cs the Logger.cs and StopForumSpam.cs who also leave the default. This done, the remaining 7 miles starting to work.
Short'm crazy because I'd like to integrate such YouTube videos or MP3 or XLIGHT.
Another thing: I had to give the permission in writing to the web.config file is normal?
I started with version 1.5.0.7 and 1.5.1.43 now I have the latest patches but the problem persists with all versions.
My site is www.francescocutolo.it
There steal any more time and I thank you in advance for your patience.
Ciccio
P.S. Forgive my English

Ciao,
innanzitutto scusatemi per il disturbo ma vorrei aiuto per un problema che ho.
Ho installato BlogEngine nel mio spazio web e devo dire la verità non ho incontrato grossi problemi.
L'unica cosa che non riesco a far funzionare, sono le Extension.
Vediamo se riesco a spiegarvi cosa mi succede.
Se già lascio quelle di base mi succedono le cose più strane. O quelle esistenti smettono di funzionare, o alcune funzionano ed altre no, o addirittura scompaiono dal Pannello di controllo dell'Extension Manager. Appena installato devo per esempio eliminare la AkismetFilter.cs, la Logger.cs e la StopForumSpam.cs che pure escono di default. Fatto questo, le rimanenti 7 mi cominciano a funzionare.
Insomma stò impazzendo perchè mi piacerebbe integrare per esempio i video di youtube o mp3 o xlight.
Altra cosa: ho dovuto dare le permission in scrittura sul file web.config è normale?
Sono partito dalla versione 1.5.0.7 ed attualmente ho l'ultimissima patch 1.5.1.43 ma il problema persiste con tutte le versioni.
Il mio sito è www.francescocutolo.it
Non vi rubo altro tempo e vi ringrazio anticipatamente per la pazienza.
Ciccio
P.S. perdonate il mio inglese

Jan 16, 2010 at 2:04 PM

Same weird things happen to my installation. I tried everything to solve this problem (downloaded web only version, downloaded source files, recompiled, recompiled agains, reinstalled... I even upgraded to 1.5) but couldn't. Any ideas?

PS: For instance, BreakPost.cs work fine at Visual Studio's web development server at my box but won't work when I upload the application to my webserver!!!

Coordinator
Jan 16, 2010 at 7:44 PM

It is almost always file access permissions on you server. Check out this post on how to verify permissions, it might help.

 

Jan 17, 2010 at 6:29 AM

Hello Again and thank you for helping. I read your blog post, and carried out checks. Permissions seemed OK (only App_Code/Extensions/tmp.txt returned error and this was because my app was precompiled). But just to make sure, I deleted everything, switched to nonprecompiled. Given appropriate permissons, Checked again with your check script, all seemed OK permissions wise. But still extensions won't work. While trying I got an XML root element missing exception (extension manager.cs line 226 I think) but when I hit refresh, it was gone, app was working again -without extensions.

Any other ideas?

TIA

Jan 18, 2010 at 2:51 PM

I solved the problem by inserting into the file wed.config administrative credentials of the provider which I have web space:

<system.web>
      <identity impersonate="true" userName="XXXXXXX" password="XXXXXXX" />
       .............

</system.web>

Jan 19, 2010 at 9:27 AM

That doesn't work with public hosting companies. Anyone solved has any idea? TIA, Haluk

Coordinator
Jan 20, 2010 at 4:25 AM

What version of BE are you using?

If you're getting an error on line 226 in the Extension Manager, that might be an old problem that was fixed.  See the 2nd post in this thread.