This project is read-only.

Every time I change settings, I get 404 error

Topics: ASP.NET 2.0
Jan 18, 2010 at 3:49 PM

I installed BE without issue, made all files in App_Data read/write, gave Network Service write permissions on App_Data folder, and set my BE installation folder as an IIS application. (I'm using SoftSysHosting, and apparently DotNetPanel creates applications whenever you create a virtual directory, even if the virtual directory is under the root site folder. So that's what I did.)

I can see my blog, login as Admin, and change the Admin password, but every other change I make doesn't get saved. Whenever I commit the change (say, by clicking "Save Settings") I get redirected to the error404.aspx page. The resulting URL looks like this:

Even though does indeed exist.

What am I missing?

Jan 18, 2010 at 5:40 PM
Edited Jan 18, 2010 at 5:44 PM

I have recently ran into similar problem, turned out to be a trust level issue. BE designed to run in medium trust, but it looks like sometimes hosts can "customize" trust level, so even when it set to medium some code still can have issue with execute permissions. Try to elevate trust level for your application if provider let you to, here is MSDN article with detailed info:


that might help too:

"I solved the problem by inserting into the file wed.config administrative credentials of the provider which I have web space:

      <identity impersonate="true" userName="XXXXXXX" password="XXXXXXX" />


Jan 20, 2010 at 1:48 AM

Thanks for this information. My hosting provider claims that all ASP.NET applications run in Medium Trust by default. (You can ask to have an app elevated to Full Trust.) Is there something I can do to figure out what is causing the 404 error? Is there a log I can look in? (The App_Data\log folder didn't appear to have anything like that.

I didn't yet try the impersonation trick, I will try that if I can't figure out the exact problem (and if they won't elevate BE.NET to Full Trust).


Jan 21, 2010 at 3:16 PM

FYI, my BE.NET installation has been elevated to Full Trust and now it works correctly. I do have to supply my hosting credentials when I change a setting, which seems kinda weird, but they are apparently cached, so it's not too annoying.