This project is read-only.

install on remote served failed

Jan 21, 2010 at 9:54 PM

I set up blogengine on my local server just fine but when I copied it over to my remote server and tried to run I got the following error message:


Configuration Error

Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately. 

Parser Error Message: It is an error to use a section registered as allowDefinition='MachineToApplication' beyond application level.  This error can be caused by a virtual directory not being configured as an application in IIS.

Source Error: 

Line 14: 					<section name="roleService" type="System.Web.Configuration.ScriptingRoleServiceSection, System.Web.Extensions, Version=, Culture=neutral, PublicKeyToken=31BF3856AD364E35" requirePermission="false" allowDefinition="MachineToApplication"/></sectionGroup></sectionGroup></sectionGroup></configSections>
Line 15: 	<BlogEngine>
Line 16: 		<blogProvider defaultProvider="XmlBlogProvider">
Line 17: 			<providers>
Line 18: 				<add name="XmlBlogProvider" type="BlogEngine.Core.Providers.XmlBlogProvider, BlogEngine.Core"/>

Source File: c:\hosting\webhost4life\member\deneen95\blogengine\web.config    Line: 16 


Any suggestions?

Jan 23, 2010 at 7:35 AM

The folder you install BE into has to either be the root folder of a Web Site or the root folder of a folder marked as an Application in IIS.

It sounds like your Web Site is in the "deneen95" folder, and you installed BE into a sub-folder named "blogengine".  You can do this, but you need to mark the "blogengine" folder as an "application starting point".  It looks like your site is hosted at webhost4life.  They might have an option in their control panel or via a support ticket to do this.