Error when adding comment after upgrade to 1.6

Feb 4, 2010 at 11:41 PM

I upgrade from 1.4.5 to 1.6 with many of same issues found here by others. Thought I was home free as all looked to be working. However, when I add a comment locally, I get the following error in a JS popup:

   "Multiple controls with the same ID 'd9ada63d34624c72908e9d35f0acce40' were found. FindControl requires that controls have unique IDs."

When I try this on production I get a similar error but the popup there says:

    "There was an error in the call back."

Any ideas?

Thanks!
Great release BTW!! Almost there.

 

 

Feb 5, 2010 at 7:23 PM

Ok got this working by doing a more thorough job of merging my existing theme style.css (illacrimo) with the same file in the Standard theme. I switched themes and realized comments were working there so must be a theme problem. Not sure what resolved it but now my illacrimo style.css is much more in sync with the Standard theme.

Comments

I just received a test email that notified when a comment was added. The Delete and Approve links were a very welcome surprise. Still trying to figure out the Comments settings section. I have Askimet stuff setup and should be working. But I have a few good comments showing up in the Inbox that I can only mark Spam (they are not) or Delete (don't want to do that either) so not sure what to do with them. Having an Approve button there would nice even after switching to the automatic mode. Hope this makes sense to someone. I was just about to leave BE behind due to the amount work needed to remove the SPAM comments that were getting posted....but now I have hope things will be better.

Thx

 

 

 

Coordinator
Feb 5, 2010 at 11:02 PM

Glad you figured that out.  I wouldn't never guessed the problem to be the style.css file!

When in Automatic Comment Moderation mode, the Inbox contains all the "approved" emails.  If they are actually spam, you can mark them as Spam or Delete them.  If you mark them as Spam, they will go into the Spam folder.  Whenever a new comment comes in, if it is determined to be spam, it will initially appear in the Spam folder, rather than in the Inbox.

If you were in Manual Comment Moderation mode, then the Inbox contains "unapproved" emails.  And you need to either Approve or Delete them.  If you approve them, they will move into the Approved folder.