BreakPost Issue

Topics: ASP.NET 2.0, Controls, Themes
Feb 9, 2010 at 6:38 PM

Hi I have a new Install of Blogengine Version 1.6. I installed it in a sub directory ~/blog/  in my existing web application. I then created a new theme. All is working except for BreakPost?

When I add [more] to the body of my post and click "Only show description of posts"  from the admin Settings Tab all I see on my Blog Main Posts page is this:

The Title by Administrator February 08, 2010

... [More]

 

Can anyone please help to figure out what is happening to the content before the [more] text?

PS: I have looked at the other themes in the installation and they perform in the same manner.

 

Thanks in advance,

J

 

Coordinator
Feb 9, 2010 at 8:48 PM

The breakpost [more] feature and the "Only show description of posts" option should be used separately.  This isn't clear ... so can definitely see how you wouldn't know.

If you use [more], then leave the "Only show description of posts" option unchecked.

And vice versa, if you use "Only show description of posts", then don't use [more] and either provide a description at the bottom of each post, or I think you can set the number of characters that is shown as a 'description' if a description is not explicitly left.

Feb 9, 2010 at 9:09 PM
Hello and Thanks for the Quick Response!!
That worked great...

Have a great day,
John

On Tue, Feb 9, 2010 at 1:49 PM, BenAmada <notifications@codeplex.com> wrote:

From: BenAmada

The breakpost [more] feature and the "Only show description of posts" option should be used separately.  This isn't clear ... so can definitely see how you wouldn't know.

If you use [more], then leave the "Only show description of posts" option unchecked.

And vice versa, if you use "Only show description of posts", then don't use [more] and either provide a description at the bottom of each post, or I think you can set the number of characters that is shown as a 'description' if a description is not explicitly left.

Read the full discussion online.

To add a post to this discussion, reply to this email (blogengine@discussions.codeplex.com)

To start a new discussion for this project, email blogengine@discussions.codeplex.com

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe on CodePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at CodePlex.com




--
John Nielson
520-568-7375
Mar 3, 2010 at 1:52 AM

Hi!

this solution does't work for me. I still getting the ...[more]
Any ideas?

Dec 30, 2010 at 8:35 AM

The problem is in  User Controls/PostList.ascx.cs. DescriptionCharacters is zero. 

 

Add the following line at Line 134 ( after  postView.ShowExcerpt = BlogSettings.Instance.ShowDescriptionInPostList;)

   postView.DescriptionCharacters = BlogSettings.Instance.DescriptionCharacters;

Thanks,
Raj
Dec 31, 2010 at 10:41 PM

this fix worked....except for another bug...when the post is collapsed all the formatting is lost. i.e, new lines etc dont appear in a collapsed view

Coordinator
Jan 1, 2011 at 6:21 PM

Hi.  What do you mean when the post is "collapsed"?  Do you mean on the homepage when you're looking at the description of the post, there is no formatting?  If so, I believe HTML formatting is intentionally removed from the descriptions.  This is because if the description is the first 150 characters (for example), and everything after that is cut off, you would end up with invalid HTML since there would be opening HTML tags without closing HTML tags.

You might want to consider instead using the [more] extension by placing [more] in your post where you want the description to be cut off.  The [more] extension will preserve the HTML and has functionality built in to close the opening HTML tags.  The [more] extension btw, is the BreakPost extension that this topic is talking about.  If you use the [more] extension, you should not use the Show Description option (i.e. turn it off).  Either one or the other should be used.