This project is read-only.

Where did my iframe go?!

Aug 9, 2007 at 5:29 AM
I created a blog post which contained an iframe (using Windows Live Writer).
Posted it and it appeared fine.

Edited the post (in BE.N) to add some tags (as I can't add new tags via WLW yet it appears) and didn't check that the iframe was still there (so I'm not sure if that's what did it)

Got home and wanted to show someone the post specifically for the iframe... and it wasn't there!

Was it the BE.N edit (I'll try and put it back in again later when I find the code fragment!) or does BE.N do some sort of timed republish that tidied up HTML and removed potentially bad stuff?! I'm hoping it's just an edit issue!
Aug 9, 2007 at 12:50 PM
My best bet is that it's the TinyMCE editor that flushed it. Maybe that can be setup so that it doesn't flush those tags. I'll give it a look
Aug 9, 2007 at 6:38 PM
yup, it appears to be the editor :(

tried to put the iframe back in via the HTML view but when I went back and saved it.... it didn't save
Dec 5, 2007 at 8:19 PM
Edited Dec 5, 2007 at 8:26 PM
Here's the solution for iframe

open tinyMCE.ascx under admin folder, then under tinyMCE.init add:

extended_ valid_ elements : "iframe src width height name ",

then you can use iframe normally.
Dec 6, 2007 at 6:10 AM
does that let you go back in and edit as well?
There was a similar solution (not sure it was exactly the same) posted a while ago that let you enter it initially but if you went back in to edit the post then it went away again :(

I use Live Writer now for all edits and avoid the issue
Dec 10, 2007 at 4:58 AM
Yeah, it's probably not the best solution, i could open the page and edit, but all the fancy options of WYSIWYG editor disappeared. hmmm.... this sucks

anyway, how do you use live writer?
Dec 11, 2007 at 3:54 AM
If you do to and download Writer then configure your blog you can open existing posts (I think within the last 20 posts) or write new ones completely in the editor. It supports WYSIWYG editing as well as a "raw" HTML view (and even has an option which previews your page in the current BlogEngine theme before you post)

If you're working with iframe you can swap in and out of the code/wysiwyg views. If you are working with script tags I recommend staying the HTML view
Apr 6, 2008 at 5:51 PM

OffBeatMammal wrote:
I use Live Writer now for all edits and avoid the issue

That worked for me- I was getting a teeny bit frustrated with trying to get my Google spreadsheet iframe embedded in a post or page.

Feb 3, 2009 at 5:24 PM
We were having problems with IFRAME and the latest version of BE/TinyMCE.  We did the following and it now works:

extended_valid_elements: "iframe[src|width|height|name|align|frameborder]",

One thing to note is that there is no space between iframe and [src. Hope this helps someone out there that may be having the same issue.