Extremely Slow

Topics: ASP.NET 2.0
Sep 22, 2007 at 5:08 AM
I just downloaded the new version and notice a major performance problem.

Here is the error I see in log file. I am not sure it that has anything to do with it: I am going to roll-back.

Process name: w3wp.exe
Account name: NT AUTHORITY\NETWORK SERVICE

Exception information:
Exception type: SocketException
Exception message: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond

Request information:
Request URL: WebResource.axd?d=7ldD2Zo4xUY2BOvbk7BJrjj3venRixXAfIkebFTLR1N9sVUtsWaHRBE74GtwWta2mLM4cFJ7HRnokz7YQ2syug2&t=633259699884321496
Request path: /WebResource.axd
User host address: 172.21.49.80
User:
Is authenticated: False
Authentication Type:
Thread account name: NT AUTHORITY\NETWORK SERVICE

Thread information:
Thread ID: 1
Thread account name: NT AUTHORITY\NETWORK SERVICE
Is impersonating: False
Stack trace: at System.Net.Sockets.Socket.DoConnect(EndPoint endPointSnapshot, SocketAddress socketAddress)
at System.Net.Sockets.Socket.InternalConnect(EndPoint remoteEP)
at System.Net.ServicePoint.ConnectSocketInternal(Boolean connectFailure, Socket s4, Socket s6, Socket& socket, IPAddress& address, ConnectSocketState state, IAsyncResult asyncResult, Int32 timeout, Exception& exception)
Coordinator
Sep 22, 2007 at 11:46 AM
It seems that the WebResource.axd compression module is creating trouble for you. Try turning off HTTP compression in the admin settings and see if it helps. My guess is that it will.

What browser are you using and do you run in Medium trust?
Sep 23, 2007 at 2:29 AM
Ok, that was the problem. I did disable it and it is back to normal. I did not have to do this on previous versions? why now?
Coordinator
Sep 23, 2007 at 11:37 AM
It must be the WebResource.axd compression which is fairly new. Is the installation running in Medium trust?
Sep 24, 2007 at 3:36 AM

madskristensen wrote:
It must be the WebResource.axd compression which is fairly new. Is the installation running in Medium trust?


It is high trust.