XmlBlogProvider error in web.config file

Topics: ASP.NET 2.0
Sep 22, 2007 at 6:20 AM
i downloaded the web project .. when i deployed it i m getting following error


Configuration Error
Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

Parser Error Message: It is an error to use a section registered as allowDefinition='MachineToApplication' beyond application level. This error can be caused by a virtual directory not being configured as an application in IIS.

Source Error:

Line 9:
Line 10: <BlogEngine>
Line 11: <blogProvider defaultProvider="XmlBlogProvider">
Line 12: <providers>
Line 13: <add name="XmlBlogProvider" type="BlogEngine.Core.Providers.XmlBlogProvider"/>

wht sould i do to remove this error
Coordinator
Sep 22, 2007 at 12:40 PM
Do you have the BlogEngine.Core.dll file in the Bin folder?
Sep 22, 2007 at 2:38 PM

madskristensen wrote:
Do you have the BlogEngine.Core.dll file in the Bin folder?


yup i do have BlogEngine.Core.dll file as well as BlogEngine.Core XML file in bin folder
Sep 26, 2007 at 4:54 AM
I am getting this same error.

I followed the instructions here:
http://www.rooijakkers.net/Blog/post/MySQL-Blog-Provider-for-BlogEngineNET-11.aspx

...to use the MySQL provider.

Any ideas what else I can try? Just trying to run it locally now with XP, IIS6.

Thanks for any help.
Sep 27, 2007 at 8:47 PM
I had a similar issue. Once I corrected my connection string for the SQL connection, it worked just fine. So basically, is your SQL connection string correct?
Sep 28, 2007 at 4:04 AM
Thanks for the tip...removed the MySQL stuff and it worked right away using just the XML provider. I don't need to use MySQL I was just playing with it so this will work. Thanks!!