This project is read-only.

AppData permissions issue

Oct 16, 2007 at 6:09 PM
Sorry if this has been covered, but a search didn't turn up anything useful.

I have done all the folder permissions correctly, and have even gone so far as to grant Full rights to Everyone in my dev sandbox. That is the only way to avoid getting an "Access Denied" error when I save config changes. I had granted full control to the IUSR, Network Service, and my local domain account without success.

Any ideas of exactly what might have been missed. I have repeated the steps and re-validated my process 3 times.
Oct 16, 2007 at 9:33 PM
ASPNET is the one that needs full permissions on the App_Data folder.
Oct 17, 2007 at 2:22 AM
G'day rhking,

What you'll need to do is right click the App_Data folder, and under the general tab, deselect the Read-Only check box at the bottom. Then navigate to the security tab and add ASPNET and apply write permissions to it.

I had that exact problem a few days ago and this fixed it after many headaches.
Oct 18, 2007 at 2:31 AM
Can you be more explicit? Are you in IIS or in Windows Explorer?
Oct 18, 2007 at 3:38 PM

AnthonyGrace wrote:
Can you be more explicit? Are you in IIS or in Windows Explorer?

Well, both. Some permissions are controlled via IIS, and some are folder permissions.

Anyway, the root cause was my late night session - granting full to ASPNET got missed, and that fixed it.

Thanks to Joshua and cvandal for the reminder. :(