IIS 7.0 on Vista ssues

Topics: ASP.NET 2.0
Dec 13, 2007 at 8:17 PM
OK, I've seen some things concernign this here but nothing that has helped so far. I installed the download per the instructions, set the right "rights" on the APP_DATA directory, chenged the application pool, etc. This is on Wiondows Vista and IIS 7.0, current released veriso of BlogEngine. All I get is the following when I ry to open the app in a browser:

Server Error
--------------------------------------------------------------------------------
HTTP Error 500.19 - Internal Server Error
Description: The requested page cannot be accessed because the related configuration data for the page is invalid.
Error Code: 0x80070005
Notification: BeginRequest
Module: IIS Web Core
Requested URL: http://localhost:80/BlogEngine.NET
Physical Path: C:\Users\shamilton\Downloads\BlogEngine\BlogEngine.NET1.2(web)\BlogEngine.NET
Logon User: Not yet determined
Logon Method: Not yet determined
Handler: Not yet determined
Config Error: Cannot read configuration file
Config File: \\?\C:\Users\shamilton\Downloads\BlogEngine\BlogEngine.NET1.2(web)\BlogEngine.NET\web.config
Config Source:
-1:
0:

More Information... This error occurs when there is a problem reading the configuration file for the Web server or Web application. In some cases, the event logs may contain more information about what caused this error.
--------------------------------------------------------------------------------
Server Version Information: Internet Information Services 7.0._

Anyone have any ideas for me here, I would be greatly appreciative.

Steve Hamilton
Dec 14, 2007 at 2:23 AM
Try following some of the steps documented at Using ASP.NET 2.0 SQL Membership and Role Providers. When I documented those steps I was using Vista and IIS 7. I think Step 1 is what you need to do.